Flint 2 (GL-MT6000) wan ISP configuration


I’ve recently bought a Flint 2 to replace my ISP router. I got ISP information regarding VLANID and connectivity through ONT. I tried to configure it on Flint 2 using DHCP connection with VLANID 1074 configuration, but no IP is got from ISP provider.

I’ve also tried to configured it using LUCI GUI, but still same issue, no internet connection at all. I saw a video describing how to connect to same ISP as mine, but with an older openwrt version. This is the video link (https://www.youtube.com/watch?time_continue=2&v=4AzpzHHr-AM&embeds_referring_euri=https%3A%2F%2Fdirectoalgrano.net%2F). I tried to do the same in new openwrt version, but I didn’t manage to achieve it.

anyone faced same problem or any ideas to be able to fix it.


Hmm can you show me how you configured it via a config file?

I would like to see the network configuration.

Though i have not the same isp, some isp lock on the mac address and block anything else until a certain threshold, but a workaround is using the mac address of the isp router for wan.

Also some of these isps their data is too old and not always consistent, its better to mail them directly.

In my case my isp supplied me with vlan 300 for internet and 640 for iptv, although after a while iptv bridge with igmpproxy was no longer needed, but neither got communicated to me, it just got deprecated and slowly broke, I then figured out iptv just worked through vlan 300 so they made it easier.

^ this is a great example isp are not always super transparant in their sudden changes :wink:, sometimes their data sheet can exist for years with wrong configuration data.

1 Like

Hi @julini, Is the suggestion that @xize11 provided works?

Hi, I’ve tested your suggestion about adding MAC ADD, but still same issue. Attached you can find the two configurations I’ve tested + some logs thrown after re-configuring.

flint2.zip (2.4 KB)

Not sure what to do next.

Mini tutorial for DSA network config - Network and Wireless Configuration - OpenWrt Forum The new version of openwrt configures vlan differently. You may refer to this.