Flint 2 low data mode on 4g dongle detection issue (multiwan)

This is a dedicated topic for the Flint 2 'low data mode' detection issue that came up on a forum with a different topic. I've created this topic so that anyone else with the same issue can follow up.

The setup

  • Plug in a 4g dongle in the usb port (Huawei E8372-608)
  • Connect and set the dongle as priority 1 in the multiwan tab
  • Set a failover WAN on Ethernet 1
  • Load exhaustible data bundle on the 4g dongle
  • Connect/tether the dongle under Internet tab

Result

Once the dongle exhausts carrier-allocated data the Flint 2 will not detect loss of internet and failover to Ethernet 1. It will continue staying connected to the dongle despite lack of internet access.

Note

I can access the default carrier website but not any other website. I believe this is what the ‘low data mode setting’ is for but it doesn’t work as intended yet. This issue is recurrent on 4.5.8 stable and 4.6.0 beta.

Acknowledgment by devs

The issue outlined above was confirmed by one of the devs and we're hoping for a fix soon.

Thanks, GL have collected this issue, and the resolution is being evaluated for improve kmwan.

1 Like

I can offer to test the patch/update

1 Like

In "Low data mode" the router stop tracking the modem interface I think.

It should switch over to the backup interface right? That's the thing...it doesn't. I have also tried using a dlink lte router and connected to the second 2.5gig ethernet port on the flint 2. Still it will not fail over to a backup lan when data is depleted in the sim of the dlink router.

Low data mode does not track the interface. So will not failover.

You can disalbe "low data mode" and it should switch.

The original problem was that Flint 2 was not failing over to backup LAN when the depletion of data in main internet source (tether set as 1st priority) did not induce failover to the backup LAN. It was suggest I try 'low data mode' to see if it will fix the issue but it didn't. My Flint 2 will not failover irregardless of the low data setting. @_zhang acknowledged a problem with the code and would work on a fix soon.

1 Like

@_zhang Any hopes on this topic?

This change will involve changes to the web page, and we expect to start releasing it in a certain version of 4.7.

1 Like

Okay, thanks for the feedback. I will wait.