Flint 2 - poor WiFi speed?

just received the router yesterday and I’m testing it.
The performance WiFi looks really poor: with 5Ghz enabled, macbook pro 2021 connected, 2 meters far from router, the speedtest is around 300Mb/sec. Previously with an asus router I saw speedtest around 7-800Mb/sec.

This is my actual configuration.
Should I change something in order to improve the WiFi speed?

Thank you.

Are you sure that your macbook connects to the 5GHz?

How did you measure the speed?

Hi @admon - yes, cause I’m using different name for 2.4 and 5Ghz

I’m using the website speedtest.net

It‘s really unusual that upload is higher than download. If you do the same test from another device (using the same test server) is it different then?

If you haven’t already, maybe try installing the beta firmware?


You could also use luci to make sure the country code for both radios is correct. Then maybe set a custom channel like 108 or 116 so that 160 MHz works via DFS.

I am having the same issue with my laptop. I thought it was a problem with the laptop but I think it might because the laptop has a “6E 11AX”.
I changed the Wi-Fi Mode to 11a/n/ac and it stable at around 500mb

Probably a bug with the ax mode.

More or less the same speed.

@blackbox I installed the beta firmware and change the country code from DE to IT but not changed the channel. Can you please explain me what DFS means? Thank you!

@wrt my macbook pro support only wifi 6 (not the E one)

I have with my MacBook m1 no problem

845.72Mbps download
35.76Mbps upload

5ghz wlan modus 11a/n/ac/ax


This morning I tried with my Pixel 7, and it’s good: 1Gb/sec in download and 470Mb/Sec in upload (I’m using fiber 2,5Ghz)
But on the macbook I cannot reach that speed.

Maybe it’s related to some Macbook settings? Strange thing is I never change them with my previous router (asus) and I was able to reach 7-800 Mb/Sec in download.

Thanks again

I use 80mhz bandwidth and get full speed with my MacBook m1 can you try that too?


and with this setting also the Pixel is reaching 600Mb/sec maxium so it seems better to stay on 160Mhz

The short version is that to actually use 160MHz you needs to use DFS channels. And depending on if other networks in your area are already using them you might benefit from manually picking the channel.

To manually find a better channel you could install WiFiAnalyzer on your Pixel and then change the channel (e.g. 100, 104, 108, 116, 120, 124) until you find one that increases your signal (e.g. from -55dBm to -48dBm).

However, you might want to try using AC instead of AX or 80MHz instead of 160MHz because the mt76 WiFi driver that the router uses has been known to have issues with some Apple devices.


I’d assume GL.iNet had WiFi fully working at it’s expected speed at one point during development, but over time changes to the driver, hostapd and EEPROM have introduced bugs that cause slowdowns.

1 Like

Thanks for your answer @blackbox
With WiFiAnalyzer I saw:

my 5G network: -51dbm , ch 36(50), -1,6mt
my 2,4G network: -51dbm, ch 6, -2.5mt

I’ve already tried to change from 160Hmz to 80 Mhz but the speed got worse
I can try to see if switching from AX to AC helps.

Thanks again.

Try channel 36, moving mode to ac/ax only
Set 23 db in luci.
Deactivate 2.4 if you are not using it.
Test again
I have mbp 2015 and im getting 7-800

haven’t changed it yet but right now looks ok.

If I set it to 11ac/ax the speed drops to 100mb. If I go back to 11a/n/ac, I get about 400mb. The only difference is the ax. Which my laptop can handle.

I don’t know, I’m really running out of ideas.
Tried again, same moment, same speedtest server, same position (less than 1mt from router)

Pixel 7: 1100Mb/sec in download - 475Mb/sec in upload
Macbook pro: 780Mb/sec in dowload - 378Mb/sec in upload

(it’s a big difference at least at download side)

Based on that result, seems that what @blackbox stated here:

the mt76 WiFi driver that the router uses has been known to have issues with some Apple devices.

could be the reason of the slowness.
(Not sure why other people with Macbook does not encounter this problem)

1 Like