Flint 2: PPPoE disconnects randomly

pppoe on wan went down randomly. Does this happen to you also?

 Fri Feb 9 05:33:09 2024 daemon.warn pppd[30701]: Timeout waiting for PADO packets
 Fri Feb 9 05:33:09 2024 daemon.err pppd[30701]: Unable to complete PPPoE Discovery 
 Fri Feb 9 05:33:09 2024 [daemon.info](http://daemon.info/) pppd[30701]: Exit. 
 Fri Feb 9 05:33:10 2024 daemon.notice netifd: Interface 'wan' is now down 
 Fri Feb 9 05:33:10 2024 daemon.notice netifd: Interface 'wan' is setting up now 
 Fri Feb 9 05:33:10 2024 [daemon.info](http://daemon.info/) pppd[31329]: Plugin pppoe.so loaded.  
 Fri Feb 9 05:33:10 2024 [daemon.info](http://daemon.info/) pppd[31329]: PPPoE plugin from pppd 2.4.9
 Fri Feb 9 05:33:10 2024 daemon.notice pppd[31329]: pppd 2.4.9 started by root, uid 0
 Fri Feb 9 05:33:25 2024 daemon.warn pppd[31329]: Timeout waiting for PADO packets
 Fri Feb 9 05:33:25 2024 daemon.err pppd[31329]: Unable to complete PPPoE Discovery
 Fri Feb 9 05:33:25 2024 [daemon.info](http://daemon.info/) pppd[31329]: Exit.
 Fri Feb 9 05:33:25 2024 daemon.notice netifd: Interface 'wan' is now down
 Fri Feb 9 05:33:25 2024 daemon.notice netifd: Interface 'wan' is setting up now

This is the ifconfig:

pppoe-wan Link encap:Point-to-Point Protocol  
          inet addr:x.x.x.x  P-t-P:x.x.x.x  Mask:255.255.255.255
          inet6 addr: fe80:xxxxxx/128 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:361677 errors:0 dropped:0 overruns:0 frame:0
          TX packets:372678 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:110141578 (105.0 MiB)  TX bytes:66661279 (63.5 MiB)

and the related pppd options into /etc/config/network

config interface 'wan'
	option device 'eth1.835'
	option proto 'pppoe'
	option force_link '0'
	option ipv6 '0'
	option metric '10'
	option username 'xxx'
	option password 'yyy'
	option vlanid '835'
	option disabled '0'
	option peerdns '1'

My isp is saying on their side, there’s no disconnection. Latest one was related to 1 month ago.
Is there a way to improve the pppd configuration? (I’m not saying this is a bug of flint2 but at least this is a strange behaviour.)

Thank you.

Are you sure your vlanid is correct?

Yes (with wrong vlanid it shouldn’t be able to connect at all)

What type of internet do you use? DSL? Fiber?

Forgot to specify, sorry. Fiber

With ONT box? Living in UK?

Yes, ONT box. Outside UK (Italy)

Okay, I don’t know what kind problem is.
Most common problem with pppoe:

  • vlanid (you could try leave blank in your router)
  • login and password (sometime l or 1, o or 0)

No, I think this is not the case.
vlanid has been configured since day 1 and this is correct.
login and password are right: if I try to change it, in the logs appear wrong username/password.
Maybe under some circumstances pppd died without any apparent reason.
I noticed the latest source available is 2.5.0 (and this openwrt version is using 2.4.9) - maybe upgrade it can help.

I don’t think so, it won’t show logs, just saying can not connect or unable to connect.

Anyway, could be locked mac address when you used pppoe previously. Try clone mac address🤔

which ONT do are you utilize ?

It’s from ZTE, specifc model is ZTE ZHXN F6005

firmware release? firmware modded?

it’s

  • V6.0.10P2N19 (OpenFiber) and it’s not modded.

Does your ISP support IPv6 ? Do you enable IPv6 in Flint 2? I have experience that if I disable IPv6 in Flint 2 the PPPoE dialing takes forever to connect to.

Your logs shows that the PPPoE client(Flint2) sent out PADI(Initiation) packet and PADO(offer) was not received (timeout) from ISP PPPoE server so Flint 2 considers the WAN port is down and repeated the PPPoE protocol negotiations again and again.

Common situations are as PPPoE needs to have VLAN ID configured, wrong PPPoE id/pwd, ethernet cable problem etc…

If everything has been tried and it still doesn’t work, contact your ISP for troubleshooting together.

(Maybe you can cross-check the issues by replacing Flint2 with other spare router to see what happens.)

1 Like

IPV6 is supported by my ISP but not enabled in Flint2.

VLAN ID: it’s configured and it’s correct.
Login/Pass: they are correct.
ethernet cable: it’s cat 8 and it works fine.

It’s randomly happens. For example: during this latest week, no disconnection at all.

My ISP said they have noticed just one disconnection on January and no more.
Really weird.

Enable IPv6 in Flint 2 to see if it works.

NAT6 is fine to test?

It should be fine to test with. (mine is Native)

Ok, I’ve put Native also, let’s see what happens.
Sound strange to me that enable/disable ipv6 can fix the issue with pppoe, but let’s check :wink:
Thank you!

1 Like