Flint 2 Problem with hardware acceleration

Hello, I’m not sure if anyone encountered this but I want to report two bugs on Flint 2 v4.5.6

In software acceleration the speed only get to 600Mbs instead of almost 1000. If I switch to hardware acceleration it’s fine going up to 1000. Not sure if this is expected but on other gl inet router I was having full speed on software acceleration.

It’s fine to switch to hardware acceleration but that creates a different problem for me. My router is configured to have an internet backup(wifi backup). While testing to see if the backup kicks in, in hardware acceleration, if I pull the primary wan cable the router is not accessible anymore. Wifi says it can’t connect and it’s not accessible on lan either. Only pulling the power cable restores the functionality.

If I do the same in software acceleration it works as expected, it switches to backup internet.

On which one? But I agree with you, the Flint 2 CPU should be fast enough to handle 1GBit NAT by software.

Isn’t the hardware acceleration enabled by default in the firmware?

Where did you change the settings? LuCi or the Gl-Inet interface?

I’ve changed the settings in gl-inet interface from software to hardware.
The other router I was talking about is gl-axt1800.

As far I know the AXT1800 doesn’t support hardware acceleration :person_shrugging:

I liked hardware acclaration on flint 2, It made speed fast ( lower ping)
But issues i had was it wouldnt let traffic counter to work. to see which device used how much internet.
on software acceration it was abit better. but still buggy traffic!
SO i turned it off all tgether. and didnt feel much differece!
To reply to the other person here…

Yes its enabled by default on flint 2
however i suggest this @adu guy to follow my thread and install Stock OWRT so u can use all the benefits of the New Lucy

Interesting article.

1 Like

Lean to read first :point_up_2:

1 Like

What I actually care about is having the full speed (around 1000Mbps) while being able to pull the main wan and the router to switch to backup without freezing. I don’t care if it’s software acceleration of hardware acceleration. This seems a common functionality to me for a high end router.
I actually like the glinet interface mainly out of commodity as I’m not planning to spend too much time fidling directly with a stock openwrt version.

1 Like

I noticed the same issue long time ago when I first got my hands on the Spitz. I recall disabling it altogether from the gl interface and enabling it from LuCi fixed the issues. Try that it may help.

1 Like

Sorry i didnt see that part. read quickly

1 Like

are there any 1000Mbps real internet speed? or by 1000 do you mean transferring inside network?

Sure there are. I have 1000Mbs internet speed over fiber optics.

So, I was fiddling with the router today (Flint 2).
I reset it (after made a backup) and made the connection again to the internet. I noticed that by default the hardware acceleration is enabled. The speed was close to 1000 and it when I pulled the wan cable out it wasn’t freezing anymore. Now this was interesting and I initially thought that there is a setting I have on the router. I added the the backup internet by wireless and pulled the cable again and it was still working.

As I was getting more curious about what was causing the freezing I compared the files in the backup with the files in the backup of the freshly reseted router and what I noticed that in the backup that was causing issues I was missing a line in the rc.local file (this is the startup file).
The line was:

. /lib/functions/gl_util.sh

After I added this line to the rc.local the router didn’t got stuck anymore. So I suppose there is something running there that is setting some configuration on this specific router.