Flint 2 WAN access not working

I purchased a Flint 2 (MT-6000) router and wanted to create the same setup as I have it with my AXT-1800. There is a Windows server connected to the Flint2 via LAN, which resources I need to access via the WAN port. I opened the ports 137 and 445 for SMB and 3389 for RDP in the Firewall port forwarding settings. For better illustration, I’ve attached the Firewall port forwarding rules from the Flint 2 and the AXT-1800

I can’t access the Windows server via RDP when I connect to the MT-6000. When I plug in to AXT-1800, RDP access works and also the SMB access.
What I tried so far:

  1. I tried configuring the MT-6000 from scratch. No success.
  2. I made the port-forwarding requests in the LUCIE GUI. No success.
  3. I pinged the mentioned ports via Advanced Port Scanner. Only ports 80 and 443 are available.
  4. I disabled the Windows Server firewall, to see if the problem lays here. No success.

Has anyone similar problems with the MT-6000 device?
Any advice is highly appreciated. I really would like to use the Flint 2 as a replacement for the AXT-1800


Did you install plain OpenWrt or why do you not use the GL GUI for creating FW rules?
(And I hope you are aware that using a firewall but opening ports for SMB and RDP is … not that smart.)

As you can see screenshot suffix GL - *** that mean made firewall in GL gui :smirk:

Both routers are within a LAN. Firstly, I used the GL GUI to implement the FW rules, and then LUCI. Both didn’t work. RDP and SMB access works only within the LAN. There is a Fritzbox above all, which creates the LAN and works as a DHCP server.

Did you change your network? Windows Firewall needs to be aware of the new network as well. Disable the firewall (only for testing!) to see if that’s the problem.

I tried using pinging the ports from the WAN side, that’s not working as well. Somehow, the port forwarding isn’t working. A port scanner doesn’t show any open ports except 80 and 443.

It’ll probably be much, much easier to just pull a backup fr your Flint v1 then cherry pick fr the tarball (via 7zip) the confs to upload to your Flint v2. See the attached HOW-TO; there’s a caveat when it comes to custom firewall rules.

This all assumes the Flint v2 is still running iptables & not nfttables as the mainline OWRT 23.05 is now based on (opkg list-installed | grep iptables).

I would use the Flint v1 to port scan the Flint v2 via nmap (opkg update; opkg install nmap).

No need for assumptions. It does run iptables.

1 Like

How fortuitous for OP. How detrimental for moi. Oh well; PBR via custom build it is, then.

I’ve reverted my Flint 2 back to firmware 4.5.0, just to see if the firmware is the issue.
I’ve created all the firewall rules in the Gli-Net GUI and suddenly the access via SMB and RDP works.