Flint (4.x) update brings down my home internet for hours!

That is step #3 :laughing:
I am having Tshirts made that say : Everbody knows how to Uboot, till they need to Uboot.

I don’t know how many times I have put the Static IP in as


The problem isn’t the gl equipment. It’s the ISP router.

I have the same problem. I’m running a MINIMUM of 47 devices at any one time and sometimes as many as 55, and increasing all the time. My ISP router seems to be limited on how many IP addresses it will be able to see, like most modern routers (and any service in the UK) they seem to be limited capacity.

My fibre router will crash roughly once or twice per hour which results in a 5 or 10 minute reboot, in the mean time the entire house grinds to a halt and no lights or switches can be used wirelessly. I have to get up off my a**e and do it myself… In the 21st century! 1st world problems.

My solution was to buy a XIAOMI 5g phone off ebay, because most phones allow unlimited private ip addresses and xiaomi are cheap, a gl.inet router to connect the phone and a mesh system together, fabricobble a network and now I have very few issues with reboots and disconnects.


My mesh is meant to be 1200mbps yet I can’t seem to break the 60mbps barrier. The gl router can easily make 300mbps but the mesh behind it can’t. Win some, lose some.

Has been up for 3 days 9 hours at 93% used (363mb) memory with 18% cached (70mb). The only thing I have not done is Run: echo ‘3’ > /proc/sys/vm/drope_caches which I will do soon to see if that makes it happen.
Theory That when cached memory is dropped that what every application is consuming memory (I think its adguardhome) will take too much and crash the router

Do you open admin panel? There are memory leak in nginx which will be fixed in release 3 these two days.

Bug Report
After making a config backup in LuCi, resetting to default and downloading a package (sqm script and luci output so feeds work) can not update distfeeds or packages after reuploading made config backup.

Nothing changed it feeds.

I tested the restore config backup work okay. Do you have more details, like an error report screenshot?


update to flint uboot 20220711 using instructions listed above (with firmware beta 4.1)

  1. All config settings/GUI were retained. Not wiped to default
  2. never could figure out what version of uboot I was running before updating
    a) version not reported on
    b) version not reported in luci interface

So - uboot updated without too much trouble

The version is at bottom of the uboot upgrade page. or
uboot2.0 version:22.07.10 is the latest one.

So a fresh system all default settings, the distfeeds and packages update and download with no problem. With wireguard client running, I get errors with updating distfeeds and packages stating no internet check network settings.

Its either trying to search using IPv6, or a firewall rule and or zone needs to be changed.

It can’t use ipv6 because it is not supported by the vpn

If anyone has a good guide on how the firewall/firewall zones works would be appreciated

Not that it makes a huge difference but should input for WAN be reject and I think one of the Masquerading is extra?

Force wget to use ipv4 only maybe a solution. I don’t have an environment to test, you try FYI.
Why not disable ipv6 totally?

1 Like

Both wan and wgclient need masquerading to work.

1 Like

This did not change the situation distfeeds are still blocked for some reason when when wgclient is enabled.

Finally, I found a simpler solution. That’s to delete the ipv6 address of wgclient interface:

uci delete wireguard.peer_831.address_v6
uci commit wireguard

Then redail wg client again.

NVM; I was trying to update the A-1300 :man_facepalming: