Flint AX1800 poor wifi speeds


I just recently purchased the Flint AX1800 and everything went smoothly initially. I have gigabit service. I was getting full gigabit speed connected through ethernet to my pc. The wifi speeds were fantastic. I was getting about 800mbps from my Pixel 7. And about 5-600 mbps to other pcs through wifi. I upgraded to the latest firmware and every thing was still fine. There was a really bad thunderstorm that came through so I unplugged all cords from the router so it wouldn’t get fried in case of a lightning strike. Once the storm passes, I plugged every thing back in. The router works great through the ethernet. Full speed. But wifi will not go over 300mps even standing right next to the router with my Pixel 7. Same goes for every device connected to wifi. I’ve tried factory resetting it. Nothing works.

Any suggestions?



1 Like

Update. I figured it out. The timezone was set incorrectly on the router and my PC. I fixed the timezone on my pc and then it synced correctly. Gave it a reboot and the wifi speeds are back to normal again.

1 Like

I think timezone doesn’t have an impact on wifi speed. Maybe you use auto channel while some channel is bad when you do wifi speed test. Try to set a fixed channel.
Also if you use Ookla speedtest.net, the server may vary and get different results.

Hello, Do you use 4.1.0 release 6 firmware, right? Does poor wifi speed happen again?

Same issue, i have tested today

4.1.0 release 6 broke download speed fine upload

4.1.0 release 5 broke download speed fine upload

4.1.0 release stable release: broke download speed fine upload

all don’t work , this feels like a bios change in one of the updates rather than one of the updates itself, regardless of the version I am throttled,

cant find and cpu temps anywhere, this feels like a recent limitation

From testing its nothing to do with the server, its the routers wifi, as the test ran 10 times on ethernet gives the same results every, then on the same network but wirelessly with a known symmetrical upload and download being 720-800 meg the speed drops, no idea when as I set my router and forget it (or so I thought) its now 350 D and 650 UP

ive just plugged in my old router and Im getting the expectd results of 750-800 Mbps per second on the same machine.

This rules out the server, the speed test provider, the computer and the network settings, the common denominator here is the Glinet router

1 Like

Hi elpmeh, have you tried firmware version 3.214 wifi speeds? Is it the same with version 4.1.0?
Could you tell me your old router model?

It seems to be a openwrt issue as it is affecting multiple routers brands.

Just got back and going to run speed test using speedtest-netperf package

ill wait for a 4.xx. patch mate , 3xxx was a nightmare for me,

I am on 4.1.0 (FLINT), I am not facing any internet speed reduction. It is the same as with 3.x firmware.


I did reboot flash, hard flashed it no upgrade, my bandwith is terrible, had to switch back to my old router for the time being as this just isnt cutting it, im loosing 400Mbs on the download and about 200 on the upload, i was getting 750 symetrical at some point in the past, on my router that came with my ISP that does the expected 750mbps as it should, so the issue is the GLinet router not my internet. getting 980 symmetrical on ethernet too,

any fix?

Can you confirm you are using firmware 3.214, not 4.x?

To obtain usable speed test data please use iperf3 in SSH

Are you using iperf3 client or server on the router cpu? The router may not be able to handle packet processing and iperf3. This can cause a drop in throughput on iperf3.

Nah mate, i could flash back but i had serious issues with being kicked off wifi all the time on 3.x and the settings wont carry back, already wiped it once in the last week, post up when its fixed! Cheers!