Flint AX1800 terrible speed

Hello. I have a new Flint AX1800 connected behind a T-Mobile 5G home internet gateway. When my computer is connected directly to the T-Mobile gateway I get 100 Mbps download speeds. When my computer is connected to the AX1800, I get 20 Mbps. I know that involves double NAT but that speed loss is terrible.

I want to use a router behind the T-Mobile gateway because there is almost no control in the user interface of the gateway. The only thing a user can do is to change the LAN address range, change the WiFi SSID and password, and turn the WiFi off.

Other users on reddit.com/r/tmobileisp report success using a router behind the gateway, with little speed penalty. Is there anything I can do to improve performance?

What you describe should not really be happening and you must have some fault in the system. Have you tried swapping the ethernet cable and have you tried resetting the Flint or re-flashing the firmware?

No, to all of the above. The cable is the one that came with the router. I’ll try another. If that doesn’t improve, I’ll reset, then move on to reflash as a last resort.

The current version is 3.207. It’s not listed on dl.gl-inet.com. The most recent stable version is 3.203. What’s the recommended version?

I (and some others here) have found this to be the most stable version:


See here:

Hope you get it sorted.

Is there any way to run a speed test from the console of the router, to limit variables?

Speedtest.net shows 9.28 Mbps down with a new CAT6 cable. When I switch my WiFi connection directly to the gateway I get 68. Ping is in the low 50s in both tests. I’ll reset the router.

Are you connecting through 5GHz or 2.4GHz wifi to the Flint?

Test speed by connecting through Ethernet cable from computer port to Flint LAN port.

Well, I just did a speed test with my Netgear Orbi (my current router) connected to the T-Mo gateway and with my desktop connected to the Orbi by ethernet. The results were similar to wifi through the AX1800. Apparently the issue is having a router between me and the gateway but others report only small speed penalties for doing so.
I have near zero control over the T-Mo gateway. I’ve read that it’s advisable to change MTU to 1420. I confirmed with ping that packets > 1392 are fragmented, so I did change MTU in both routers.

Edit: a speed test tool in the console of the Orbi just measured 30Mbps up, 35Mbps down. Ping is now shown. That’s after changing the MTU to 1492, but I don’t know if that’s relevant.

I have to table this until next week. My Orbi is now working as router through the T-Mo gateway. I’ll leave that in place to test if T-Mo can provide adequately consistent speed. (My standards aren’t high. We stream on only one 4K screen and other usage is just internet browsing.)

My reason for moving to the Flint is so I can set up the router as a VPN client. T-Mo doesn’t support a public address I can use to connect to my home network from outside. I’ll figure out the cheapest/easiest way to accomplish that later. It may be Tailscale or may be a VPS with that server forwarding ports to the Flint through the VPN.

When you have time to get back to this, can you test speed with your computer connected through Ethernet cable directly to the T-Mo gateway? Some info may help other readers on the forum.

My network has Asus router behind the ISP’s cable modem/router, so double-NAT, and I get speeds up to 200 Mbps.