Flint DNS Leaks in both Wireguard and OpenVPN

Hello, I’ve been trying to use VPN on the new Flint router with policy rules.
Unfortunately, it seems that the VPN still uses the routers DNS addresses (that I set).
Any ideas?

can you show your policy rules?

The router’s custom DNS settings is the prior settings actually.

How can I make the VPN DNS settings to be prior?

@alzhao I investigated the problem a little further, and I think there’s another Flint specific bug here.
I have tested an OpenVPN connection and a wireguard connection, and both of them ignore completely the VPN pushed DNS.
To compare I have pulled my old GL-iNet Mango (MT300N-V2) and tried connecting to the same servers I tried with flint and they accept the VPN pushed DNS without nothing on my side.

There is probably a bug on Flint, because surely this is not the intended behavior, the client should accept the VPN pushed DNS, this is how it works with every router and connection.

Understood. Developer will do analysis on this.

Is there any update on this? I’m running AdGuard home and OpenVPN and the are dns leaks.

Just don’t use Adguard and vpn together because they all need to take control of dns.