Flint Firmware 4 Upgrade Issue

Trying to load beta firmware openwrt-ax1800-4.0.0-0528.tar but getting below error.
My current firmware is 3.214, can someone advise?

Short answer: switching from firmware 3.x to 4.x, the first time you need to download the Uboot one to upgrade.

1 Like

If you upgrade from sdk 3 to sdk 4 its wisely advised to make a backup of your configuration first, you can use scp or luci via the administration button.

Then theres a PSA:
If you upgrade from version 3 to 4 you can only do this via uboot otherwise your device could be bricked the same count if you downgrade from 4.0 back to 3.0.

If done… Open your backup folder with 7zip, and manual upload some of the /etc/config files keep in mind that the network config might be changed due to the newer openwrt this config conflict since some config key types are changed.

See wiki:

Edit:
In case if it asks to keep settings then uncheck this, because this could cause troubles like a infinitive bootloop.

Before going from 3.xx to Beta 4.xx should people update Uboot or have a particular Uboot Version?

As far as I know it worked fine with the default uboot, but you have to be sure if you have a compatible firmware image for uboot some images on dl.gl-inet.com have it combined some have it appart as a secondary image, it will say it on the web page.

If its from github I think you need the factory one rather than the sys upgrade. :+1:

1 Like

How to go into uboot ? No changelog for the latest beta?
Should wait for the final firmware to update via web GUI?

I have upgraded just via web GUI and works flawlessly. Just remember to not keep settings.
I suppose download center uploaded files wrong and Uboot file is swapped with web gui one.
File I used to upgrade is here https://fw.gl-inet.com/firmware/snapshots/20220528_4.0.0_release2/ax1800/openwrt-ax1800-4.0.0-0528.img

from what I always do is the following:

first configurate a static ip:
ip: 192.168.1.2
netmask: 255.255.255.0
dns 1 and 2: 192.168.1.1

plug out all the internet cables also on wan, then connect one cable on lan port 1 and let this cable go to your pc.

now first replug the power cable and hold down the pin for 5 seconds (maybe you don’t even need to… since the site says the leds need to be white…)

then ping 192.168.1.1 if you see something then you can visit it and upload the uboot image :slight_smile:

I suspected this might be the case looking at files’ extensions.
So after the GUI upgrade will I be able to upload Luci configuration backup from firmware 3.214 and restore my settings?

Remove power.
Hold down reset button with toothpick/sim removal tool
Insert power
Front light flashes blue, flashes blue a bit quicker then goes white
Release reset button

Flint should be available at 192.168.1.1
(Need to static IP your connecting device as no DHCP server in Uboot mode)

I believe no WiFi will be available and that has to be with a LAN connection?

Correct you’ll need an Ethernet connected device.

Just FYI

I installed beta firmware v4 last week and all works OK so far.
Memory load shows 50% after 6 days. :ok:

1 Like

Hi @alzhao
Is GoodCloud supporting devices with firmware 4?
I just noticed my device is not showing online in the portal.
Also logs on router show the below despite the fact that everything
GoodCloud related is enabled on the router.

Thu Jun 23 17:25:31 2022 daemon.err mqtt[32556]: utils_NLB failed!
Thu Jun 23 17:25:35 2022 daemon.err mqtt[32556]: timestamp invalid
Thu Jun 23 17:25:35 2022 daemon.err mqtt[32556]: utils_NLB failed!
Thu Jun 23 17:25:38 2022 daemon.err mqtt[32556]: timestamp invalid
Thu Jun 23 17:25:38 2022 daemon.err mqtt[32556]: utils_NLB failed!

I tested and firmware 4.x connects to the cloud without problem.

Can you fix the time on the router and try again?

Hi @alzhao

After rebooting the router this now works.
(Time was set up correctly)

I am running firmware 4 release 2 and noticed that in OpenWRT in Software
there are loads of packages updates (in my case 69).
I have updated them all one by one and router worked fine until the reboot.
After reboot Gl-Inet web interface become corrupted (not able to log in, do anything).

So what about these packages, should they not be touched and left as they are?

Pls don’t upgrade invidual packages. I don’t think openwrt can manage the invidual config of all packages.

I wrote a guide How to upgrade GL-AX1800(Flint) to firmware 4.x?

1 Like