Flint GL-AX1800 - 2 problems + upgrade on version 4.2.0 snapshot impossible

I used same, from same url
4.2.0 snapshot

You screenshot should at least contains the hash. Maybe you can just refresh the browser and try again.

I refreshed, no change
I also logged out and logged in, nothing
and also with another webbrowser - nothing = same error

I even tried rebooting the router - same result

If you are going from 3.x to 4.x you are supposed to use Uboot and a .IMG file

Don’t forget to update uboot

1 Like

sorry, I dont know uboot
I need GUI interface

to explain:

i have MT1300, SFT1200 and AX1800
They all have the same GUI + Luci.
Uboot is something unknown to me

Yes an no the Beryl MT1300 uses NOR Flash 32MB and the Opal SFT1200 uses SPI NAND Flash 128MB the Flint AX1800 uses NAND Flash 128MB they are also on different kernels. Anyway the MT1300 and SFT1200 are updated by the GUI but AX1800 Needs uboot and it even states that on the firmware upgrade page.

Also Uboot should be updated

Uboot is simple if you follow the instructions.

1 Like

thanks, I see…I read that already


does this mean that I will buy a new Flint and do not have to update it normally through the GUI or automatically?

Well then I’ll return it, I don’t want to have problems

Just follow the instruction on the video linked in the referenced document above and you will not have any problems.

Ok guys…thanks so much…
I’ll try to do it over the weekend

1 Like

Just to be clear if you are going from 3.x to 4.x Update uboot first with the instructions from the link. You then want to reboot and check that the uboot firmware updated. Once that is done then update with the .IMG file ( I would use the Date Compiled: 2022-11-14 02:57:37 (UTC-05:00)SHA256: 6d3fcfde9f7b49aba32bce540ff698bcefc1849ae6bc8b9fc49682b123af9d56 This is a stable build 4.1.0. do a fresh install (do not keep settings) setup how you want and make a backup in LuCi of the config file and reboot. If you want to load a 4.2.0 beta or snapshot you can now do it from the GUI
Common problems with uboot are:
More then one device is connected to the wired connection of the router
You need to hold the power button/reset button before powering the router.
Use a private browser window when doing Uboot(this prevents cached pages)

1 Like

Ok k3m3l, but
Just to clarify - if I do all this according to the instructions, will I have a normal GUI for administration?
And then what next, if another update is needed?

You should see a different web page with uboot as logo, note that the end of the url must end with uboot like in the documentation because otherwise you are on the restore the firmware page, u-boot is basically your core bios where openwrt boots from.

To add: make sure before you upload anything that the image is 100% u-boot compatible and not just a firmware there might be links in the documentation or here else just ping me with a reply, because updating u-boot is usually not a standard procedure, this can hard brick ur device, so do so only when it has something broken in u-boot known in flint, you should see it as a procedure you only will do once and never hope to do it again.

1 Like

I am also facing some issues / differences on 4.1 and 4.2 beta:

  • when acting as wireguard server, doesnt respond to DNS request from inside WG tunnel. (WG not working when I set DNS = (WG server IP) in the WG client conf. This worked fine in 3.x.
  • cant reach the WG server inside the tunnel via https, although I enabled HTTPS Remote Access (this should be for WAN) and also allowed 443 in Network → Firewall → Open ports on router. Did the same for DNS.
    this also worked fine in 3.x as far as I remember
  • also had some issues when tried downgrading back to 3.x - router crashed - so now I am back on 4.1 (had to use the process explained above)
    maybe I am missing something?

It will be 4.x GL.iNET firmware


I found a fairly simple transition to version 4.0 beta: Dropbox - openwrt-ipq807x-glinet_ax1800-4.0_beta8.img - Simplify your life according to the instructions https://www.youtube.com/ watch?v=E8E5CUbK2Qo

Couldn’t I then normally upgrade from that 4.0 beta to 4.1 or 4.2? /no uboot/



I ended up having to do it based on a video I found.
First 4.0 beta, and then I was able to upgrade to 4.1.0

BUT !!!
Wireguard server does not work in this version either.

I am very disappointed with this product.

You went off scripted so I can’t help you anymore. I gave you a specific way to do it. If you set up a raspberry Pi you should be able to update uboot and the GL.iNet firmware.

Good luck

Check the vpn proxy settings in vpn dashboard if your wgclients are actually connected to may not be allowed to leave the LAN and use the WAN

If you look at the uboot thread Uboot needs to be updated to avoid issues going forword in firmware

Can someone advise on the DNS issue explained above, or should I open a separate thread?

Hi K3rn3l_Ku5h , thanks for your time.

uboot2.0 version:22.07.10

To clarify - this morning I did the whole process again - uboot upgrade to uboot-gl-ax1800-20220711-md5-9890c67c3dafa5aec172f3a31583f9a7.bin
Then upgrade to openwrt-ax1800-4.2.0-0121-1674260559.tar

Still is here problem with WireGuard

  1. I turn on the WG server
  2. I will add a profile
  3. I scan the QR configuration
  4. the client does not connect, the connection does not work

Where and what do I need to set?
In Luci? Because there is no other option in the Admin panel.
And when in Luci - what should I change there?
Something with routing? Because I’m not good at it.
Where can I find instructions for standard WG operation?

In Luci:



firewall rules

Here I tried wgserver_allow from wan to lan - same result.

P.S: Resolution: Need open specific port on Firewall - Open ports on router. In my case 51820. I am an idiot.

Thank you all for your efforts and help.

I was about ask if you had opened ports