Flint (4.x) update brings down my home internet for hours!

I updated Flint to 4.1.0 rel 2 from 3.x and lost home internet for hours from the ISP itself due to this. This is a very severe issue that gl-inet may want to look into.

My ISP is a gigabit fiber that uses an ONT with a limited DHCP capability. The ONT/fiber modem has a pretty strict number of DHCP requests for public IPs it will allow on a short period of time and once its DHCP table gets full it won’t handle any more internet public IPs for a long while. I have to call the ISP to remote reset the table, which took me hours because they were busy today.

The issue seems to be caused by Flint 4.1.0 upgrade from 3.x. At some point in the upgrade the router bridges all ports from LAN and WAN into the same net (maybe this is even happening on reboot?). This has the instant effect that all the devices in my LAN now are DCHPing into the ISP at once for a public internet IP. I have over 20+ devices on my LAN. ONT fills up its limited public IP table and locks up. Have to call ISP to unlock or maybe wait many hours?

Please take a look into this. Never had an issue with 3.x series

1 Like

@Dipin can you have a look at this issue?

That’s a uboot bug, the fixed version can be downloaded here.
Upgrade uboot by the following steps:

  1. connect LAN and PC by ethernet, the PC’s ip should be 192.168.1.x
  2. push the reset button and power it on, about 10 seconds later release the button, until the wifi led stops flashing and the white led turns on.
  3. access to flash uboot.

Does this affect other models than Flint?

axt1800 also has that issue and can be updated the same way. Newer manufactured ones will avoid that issue.

Can I use the same Uboot version on the GL-AXT1800, or do you have another link?

I do not work for and I am not directly associated with GL.iNet

Sounds promising. Will give it a try when I can allow for my home internet to be down for a while in case it messes up again.

Bug report

Flint V 4.1 release 2 from github
Memory started of at 72% 286Mb used(this is better then firmware 3.215 86% 322 Mb) and was stable for about a day then climbed to 94% 369MB. Just about 48hours the router stopped DNS request and crashed restarted back to 72% memory and working

I have WireguardVPN client working with policies, AdGuardHome doing DNS running full OISD list and SQM running.

Could you set up persistent log like the following,

and paste log attachment when crash happen.

1 Like

Does it affect your Router if you use the .tar version?


Uboot bug is not related to firmware .tar or .img version.

Do you mean by flashing the same file you’d posted above (https://github.com/gl-inet/uboot-ipq60xx/blob/master/uboot-gl-ax1800-20220711-md5-9890c67c3dafa5aec172f3a31583f9a7.bin?raw=true) ?

Yes, that’s correct…

1 Like

Please confirm if the same Uboot is for the GL-AXT1800 also.

AXT1800 and AX1800 use the same uBoot. I updated my AXT today with the file @hansome supplied.

1 Like

I fixed the problem, It reboots every day at 5:00 in the morning using GL.iNet scheduler :rofl:
No backups for me :disappointed:
So will put that on hold and let it run till it breaks.

is there a way I can check if my uboot is still working and not corrupt?

I’m unable to get it to run, plugged one cable in lan1 and powered the router gave my windows 11 pc a static ip to

now I have tried it two ways:

if I power the router I first see a idle blue light, I have tried to press the pin 10 seconds on the flint but that does not work.

then when I waited until the breathing led (blue led breathing), and I then used 10 seconds pin press I do see the router led go black and turn on white for a few seconds, but then it goes back to blue idle light and then back to breathing.

is it me or do I think uboot is hard crashing?

I believe I got a early flint from a year ago.

Early uboot will fail in certain circumstances. Please try to use incognito window of your browser.

1 Like

I figured it out, it seems I had to hold press the pin before powering the device I’m not sure why this was as I cannot remember I did this before :stuck_out_tongue:

1 Like

Before going to the trouble of re-flashing uboot.

Any way to determine current version of uboot?

Will new version of uboot cause all config settings to be lost?