Flint (GL-AX1800) - Firmware update issue


Running 3.214 firmware and struggling to update to latest stable 4.1. I tried local update with the files from the firmware update page. The router got stuck on the update and did not restart (blue?) light flashing indicating that the router was updating firmware. After 30 minutes restarted to router and it looked like it bricked. I restarted it again and it went up with 3.214 firmware and everything was running normally.

The online/automated update is not detecting new firmware so I’m stuck on 3.214 firmware. What is the best to update the router at this stage?

Had a similar issue, automatic upgrade doesn’t work, you need to flash the uboot .img file from the official website and rember to not keep settings since this will break the installation.

Hope it helps.

So the update should not take more the 5 Minutes.

Also will want to update uboot before


Oct 20

That’s a uboot bug, the fixed version can be downloaded here .
Upgrade uboot by the following steps:

  1. connect LAN and PC by ethernet, the PC’s ip should be 192.168.1.x
  2. push the reset button and power it on, about 10 seconds later release the button, until the wifi led stops flashing and the white led turns on.
  3. access to flash uboot.

Welcome to the Future :gl_emoji_woah:

Thanks both. I did use the *.img file. Perhaps I need to update the uboot as K3rn3l_Ku5h is suggesting. Will the 4.1 version of firmware become available soon for the online update so that I can avoid all the hassle with manual update?

You need make the jump from 3.x to 4.x after that it will auto update

Thanks. Okay, so looks like I have to first update uboot, and then update manual to 4.1 using the .img file. I’ll give it a try, during some low net traffic day :slight_smile:

You will need to do a complete manual setup of configuration, if you import a config file it leads to issues.

I don’t have any critical updates to configuration. Does not importing configuration mean that I will need to go through the same steps like I did when I ran the router for the first time - setting the router admin password etc?

I will likely flash the uboot, update to 4.1 firmware and then configure the router.

Also, question - do I need to have a computer with LAN port and admin to do any of the flashing or updates? I presume not, because all I do is connect with a LAN cable and upload a file downloaded from the internet.

Version 3.216 of the firmware will be available for online upgrade to 4.x.
Upgrading from other 3.x firmware to 4.x will not be supported. Because 3.x firmware cannot tell users that settings are not kept. We will be releasing version 3.216 to fix this issue.

That is a great news. When will be the 3.216 firmware be available?

This will not be soon. For older products, we first have to adapt the 4.2 version of the firmware. Not 4.1, because the older products have a smaller flash and we need to thin out the package. Also the upgrade from 3.x needs to be processed on the 4.2 firmware.
The 4.2 Beta firmware will be released next week and we expect it to be officially released at the end of this month or in January. As for 3.216, all I can say is that I hope it will be released in 2023Q1.

Hey, how is this going? Will we see 3.216 anytime soon?

It shouldn’t take long. It is already in the final stages of testing and problem fixing. 4.2 is also.

1 Like

Great. Once 3.216 is available - will Flint update automatically and then install 4.2 version? I’d love to avoid manual update from 3.214.

Yes, you just need to click on “upgrade” in the page and it will download and install automatically.

Checking in - is 3.216 coming anytime soon?

Some models of the 3.216 firmware are expected to be released within a few days. Unfortunately, however, there are still some issues with products that use QSDK, including Flint, that need to be fixed.

I updated from the 3.XXX to the new 3.XXX that said it would allow upgrade to 4.XXX. Worked fine. Then I upgraded to the 4.1 version and it seems to be bricked. All done through the standard upgrade interface on the router. What’s my next step?

I updated the firmware as well first to 3.216 and then to 4.1 thought the interface. When I hit again option to update the router it said 4.1 is the latest version of firmware.

On my end 4.1 works well though I get a message that the Wireguard client is not found. Does anyone know how to get it up running again? I installed the wireguard packages but to no avail.


I’m very sorry, but we had a problem with the release order. It should have been upgraded to 4.2 instead of 4.1. version 3.216 was released before version 4.2.
Please upgrade to version 4.2. If you can’t access admin panel, refer to Debrick via Uboot and GL.iNet download center.