Flint (GL-AX1800) Latest firmware

I have the latest firmware which is really nice, the problem is randomly, it freezes and you can’t get onto the gui all I can do is disconnect the power and that sorts it out, never happened on the version 3***.

Have you updated Uboot recently? There was a uboot bug.

Hi no how do you do that, thanks for the reply

Also will want to update uboot before


Oct 20

That’s a uboot bug, the fixed version can be downloaded here .
Upgrade uboot by the following steps:

  1. connect LAN and PC by ethernet, the PC’s ip should be 192.168.1.x
  2. push the reset button and power it on, about 10 seconds later release the button, until the wifi led stops flashing and the white led turns on.
  3. access to flash uboot.

HI thank you i will try that if i still have problems as since I’ve re rooted all clients through the VPN (I had my tv not via the VPN) its been fine.

Yes it’s still locking up I will have to update the uboot file should I give the wired pc a static ip address in the range 92.168.1.x, many thanks

Give you computer a static ip of 192.168.1.x (x is anything but 1 ). Flash the uboot uprade and apply 4.x upgrade again with uboot.
Uboot firmware upgrade page is
GL-ax1800 firmware page is

Sorry little confusing on the last two lines of your instructions, update the Uboot and re flash the new firmware, thanks where I got lost

Please read the Uboot instructions: Debrick via Uboot - GL.iNet Docs

(Uboot is your router firmware(OS) loader, when you need to unbrick or flash clean firmware, you need it for enforcing flashing.)

Above URL includes how to update your Uboot loader to newer version in section “Upgrade the Uboot version”.

1 Like

I’m currently running uboot 2.0 version 21.12.01 and want to upgrade to firmware 4.1.0, which versions of uboot are affected?

Edit: Just updated uboot to the version linked in this thread, system is now showing uboot 2.0 version 22.07.10 (the latest version).

Thank you all very much I will read up it will probably be quite easy once I’m into it, just for interest sake how do determine the uboot version, mine hasn’t been updated.

So you will need to update uboot, install the 4.x stable build firmware again and reconfigure the system.

Many thanks going to have a go most likely tonight, one strange thing while I was looking in LuCI for the uboot version I went into the network settings Interfaces I got this message attached so I hit continue not sure if this was causing the lockups.

I have encountered that message a few times on different GL.iNet routers and, after taking backups of the router settings, just clicked Continue in all cases without any problems before, nor after.

I do not work for and I do not have formal association with GL.iNet

Just tried flashing the uboot but the page was not available message keeps cumming up so i couldn’t flash it i used the exactly as in the early post instructions, the page then refreshed and went to so while i was there i flashed the firmware again, that was successful, when i got back into the router i went into the network settings Interfaces in LuCI i got the Network iframe notice again and for the second time as wcs2228 said i clicked continue and everything is working again, i have also got AdGuard back on the USB so i will see how it goes, don’t know why the uboot page was missing?
Is there a way of finding out what uboot version i have.

I just found this and apparently it tells you the version of uboot
$ strings gta02v5_and_up-u-boot.bin | grep U-Boot
But it never worked for me

The gta02v5_and_up-u-boot.bin does not exist in the directory where you first log in. It may or may not be in another directory on the router. Where did you get the information about checking that file?

If you want to try searching for the file on the router, then run the following command in SSH:

find / -name “gta02v5_and_up-u-boot.bin”

You either want to us a private browser or flushdns and chaches in browser

Hi thanks but that don’t work either

It actually “worked”, but did not return anything because the file could not be found.

You have to put double quotes (") around the file name, or no quotes at all, but not periods (.). However, the file may not be on the router.