Flint GL-AX1800 Major Breaking Bug In Beta

So it would seem that the plugins updates auto updated to broken unfinished plugins which made it so I was unable to login to my router gui and other things, my internet and wifi died and I had to do a 10 second reset to set back to factory, it would seem once a month plugins would auto update to broken plugins which made the router unusable.

Plugin auto updates need to be disabled until major breaking bugs have been fixed

This bug I would say is a major bug that needs to be seen to, I have to set the router configurations back.

I am fully aware of what beta is and I am happy to report any bugs needed to make this firmware stable for mainstream use.

2 Likes

What plugin did you try to update?

I didn’t try to update any of them, I know it’s the plug in cos when I did update the plugins a month ago they did the exact same bugs it seems it auto updates them to the broken plugins

Timezone syn shall be online and you can use the “timezone syn with browser” button to set or set manually.
I test the recently beta without any issue.

Irrelevant comment it’s nothing to do with timezone sync, I’ve already found the problem and it’s plugins that are broken not timezone syncing

2 Likes

I don’t know if this is of any relevance but I have not been able to do a manual update on v4_release3 firmware.

root@GL-AX1800:~# opkg  update
Downloading https://downloads.openwrt.org/releases/21.02-SNAPSHOT/targets/ipq807x/ipq60xx/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02-SNAPSHOT/targets/ipq807x/ipq60xx/packages/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/base/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/gl_feeds/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/gl_feeds/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/glinet/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/glinet/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/ipq807x/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/ipq807x/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/wifi_ax/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/wifi_ax/Packages.gz

Updating database.
Database update completed.
Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02-SNAPSHOT/targets/ipq807x/ipq60xx/packages/Packages.gz, wget returned 8.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/gl_feeds/Packages.gz, wget returned 8.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/glinet/Packages.gz, wget returned 8.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/ipq807x/Packages.gz, wget returned 8.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/wifi_ax/Packages.gz, wget returned 8.
root@GL-AX1800:~#

This is my release 3 on AXT1800.
AX1800 should be the same. Otherwise it may just be bugs in the snapshots.

It’s been 28 days since release 3, should we expect next release any day now?

There are no kmod packages for AX1800 4.0.

At least I am getting errors like this:

Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 4.4.60-1-5c79df825364eed582b9e6554972c148) for kmod-ipt-tproxy
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-tproxy found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for shadowsocks-libev-ss-rules:
 * 	kernel (= 4.4.60-1-5c79df825364eed582b9e6554972c148)
 * opkg_install_cmd: Cannot install package shadowsocks-libev-ss-rules.

Well, I got distfeeds.conf from AXT1800 and used it on AX1800, now there are no errors on opkg update:

src/gz glinet_core https://fw.gl-inet.com/releases/v21.02-SNAPSHOT/kmod-4.0/arm_cortex-a7/ip60xx
src/gz glinet_gli_pub https://fw.gl-inet.com/releases/v21.02-SNAPSHOT/packages-4.0/arm_cortex-a7/glinet
src/gz openwrt_base https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/base
src/gz openwrt_luci https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/luci
src/gz openwrt_packages https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/packages
src/gz openwrt_routing https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/routing
src/gz openwrt_telephony https://downloads.openwrt.org/releases/21.02-SNAPSHOT/packages/arm_cortex-a7/telephony

But kmod from it are invalid (for obvious reasons).

@hansome can you check if AX1800 has the correct opkg feeds?

The kmod package is only available for gl-axt1800. Fixed 4.0 version for ax1800 should be release at middle of July.