Flint GL-AX1800 Managed switch

Another hilarious “hack” for Flint.
There is no way to add VLANs on the switch tab of the Luci…

Is it that?
Probably not :wink:

just manually add the first VLAN by editing the /etc/config/network

config switch
        option name 'switch0'
        option enable_vlan '1'
        option reset '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2 3 4 5'

And refresh the page…


Nice find, you just stopped me from returning my Flint due to the inability to configure VLAN in Luci. I tried your suggestion and was able to segregate my home network into different VLANs. Thank you so much for sharing this.

1 Like

You are amazing!!! I wish gl-inet would make it easier to change these options in luci, like with some of the older models

Got my flint today and hit the enable VLAN functionality checkbox in luci. Couldn’t add VLANs afterwards. I’m not alone :slight_smile: Because I need VLAN7 on PPPoE WAN I just entered the custom ifname eth0.7 for WAN and it works. My Creta uses GL.iNet’s OpenWRT 19.07.8 firmware but the Flint’s firmware isn’t polished and incomplete (OpenWrt Chaos Calmer 15.05.1 a828782+r49254 / LuCI Master (git-20.353.27956-6404588)). I also have devices from other vendors with vanilla Openwrt 21.02.1 and luci material theme. This qsdk really needs to be bumped to the latest release.