Flint (GL-AX1800) reconnects to 2.4Ghz instead of 5Ghz

this topic is about a small bug that happens sometimes after rebooting the router.
If you connect and save only a 5Ghz wifi network which has both 2.4Ghz and 5Ghz signals with the same SSID and password, the device correctly connects to the 5Ghz. However after a few reboots (<10) sometimes the device starts connecting to the 2.4Ghz instead of the 5Ghz, because they share the same SSID and password.
Is possible to force only to connect to the 5Ghz and do not connect to the 2.4Ghz signal if the network user/pass for 2.4Ghz is not saved?
I understand it should connect to the 2.4Ghz if it is saved and the 5Ghz fails, but in my case connects even when I have not saved the 2.4Ghz user/password. This means that the speed is a fraction of the one I get using the 5Ghz and the device stops any reattempt to connect to the 5Ghz.

Yes you are right. This is a problem of repeater manager in firmware 3.x.

In our working firmware 4.x, we have an option that you lock your band to 2.4G or 5G.

1 Like

Iā€™m so glad I come across this! This fixed my biggest pain point of using the device! One question, can we have a similar option for extender mode too?