Flint GL-AX1800 - serious Network issues

Good Day :slight_smile:

I have the same issue on two Flints, since a couple days all my device connect to the WiFi, but I can’t open any website or start streaming via VPN.

On both devices are Wireguard VPN running, both Flints connect and both have VPN traffic!!
If I connect a new Client the first time - it works, if a Device reconnects - dead…

Flint1 is at Home behind a T-Mobile home 5G Router and provides an own Network with Wireguard VPN for streaming - worked over 10 weeks without any problems.

Flint2 is a used as Hotel Router and is wireless connected to the Hotel Network or a 5G Hotspot. also Wireguard VPN, with VPN Policies.

Firmware : qsdk-ax1800-3.212-0301

same settings with same SSID testet on Slate, Creta and Mudi - without Problems



The Flint appears to have some serious issues with WireGuard, Adguard and VPN policies running together and the slowdowns and disconnects are something else. I have a Brume which is much more stable although far from perfect as well. I have just gone back to my Asus with its Beta firmware running wireguard in the hope that these problems with the Flint are eventually resolved.


but that continues ever after fresh new flash of the firmware, without AG or VPN, just routing…

what is this new upgrade diffrences ?

i have same issue exactly

You mean the connection from the same client dies or the router dies?

the device reconnects, WiFi connection established but no website can be open. it looks like a DNS problem…


For me I also lose connections on wifi but for me the messages in the log just say deassociated.

Now I did some further digging but to my surprise some devices act different, some auto disconnect for power saving, other ones can directly disconnect when theres no dhcp, and some get connection but dont show a error it has no internet.

I think something happens when flint renews their dhcp lease, it might give a wrong dhcp server, or it might just shortly have no dhcp at all.

Could you try and test what happens if you force your dhcp?

You find it in luci->network->interfaces->your wifi interface->then dhcp, for vlans this worked for me, for wifi not but you could give this a try.

If that doesn’t work, what happens if you go use purely static routes and have no dhcp at all?

I couldn’t test this further since I think my phone does it out of energy saving, I wish there was a standard how devices act that would make diagnosing alot easier.


Just to add aswell, it could be part of rebind protection and double nat please test with it off aswell if it was enabled.