Flint (GL-AX1800) - WiFi Issues

I have setup a VPN Connection via WireGuard.
With LAN everything works.
Only the WiFi is making much trouble. I can connect to the WiFi but I cant load up anything. It will load endless.
Iam using the latest firmware.
I have to reset everytime to get my WiFi fixed. But this issue comes after some days again

So the issues is, when set up wireguard, at the beginning it works. After several day wifi do not have Internet, but lan still works on wireguard, right?

It looks familiar when I received my Flint in the first couple days, the Wi-Fi will load web pages like it’s stuck somewhere until I disable IPv6 to fix the issue. Do you have IPv6 turned on ?

My Flint even upgraded to latest firmware, when IPv6 is turned on, the situation will come again.

I still have no idea what causes this…hmmm

Yes correct
@cafebug actually I never enabled IPv6 and it doesnt enable by itself

I’m having the exact same issue. Same escenario. Not using IPv6 not activated. I just received flint today. All day trying testing different configurations with no results

Using a second router connected to flint trough Ethernet and while connected to it VPN connection works ok. Problem is the flint wifi.

Have you upgraded the firmware?

Iam using latest firware

I am experiencing this issue, latest firmware as of today, ipv6 was disabled by default and has never been enabled, while connected to my vpn via wireguard, web pages do not load.

  • I have the exact same setup on another GL device (not Flint), connected to the same VPN and it works fine.
  • Connecting via Ethernet + Wireguard works fine.
  • Connecting another router via Ethernet to Flint and using the other router’s Wifi works fine too.

How can something like this can even be fixed?

Is the wireguard your own server? Do you have more details? I can do more test to verify.

I am using TorGuard Provider as my WireGuard Server

It is my own personal server, but like I said all other peers (15ish) perform and connect just fine, I even tried switching the keys and removing some peers with no luck, of those peers, at least 3 of them are other GL.inet devices with the exact same config, all performing well, what other details would you need?

Is there an update?.. i can do screen sharing, so you can check up my router…

Sorry I was travelling.

I just tried Setting TorGuard Wireguard using smartphone app and configure it on AX1800 3.207 firmware.

My wifi works as expected. Pls note I did a clear upgrade to 3.207.

So maybe your settings was messed up for some reason. Can you do a firmware reset and try again?

I thought it could be a MTU setting problem but as you have normal Internet on cable, this should not be the case.