Flint. How to bypass VPN For all Guest devices?

I have Flint router in WG client mode with Global VPN option and I have gues network with separate LAN subnet but none of the guest n/w devices are able to access internet. Please help

First, do not use global kill switch, which blocks all traffic for non-vpn clients.

Second, use vlan-based policy and do not use vpn for guest.

I tried that. Enabled VLAN based policy and disabled VPN for guest but still not working

What is the firmware version?
The guest wifi does not have Internet or still use vpn?

4.2.1 release 4
Guests are not having internet

I am back to work tomorrow and I will have a test.

I did factory reset now and guests are getting internet but from VPN. I have VPN enabled only for private vlan and it is disabled for guests but still guests traffic going through VPN. I need guests to use local internet instead of VPN

Any luck with your testing Alzhao?