Flint Router 5ghz band freezes every few days

Almost every day or every other day my Flint’s 5ghz wave band goes “corrupt” for lack of a better term. The devices connected to the band are dropped off it and can not reconnect, also it appears the settings panel for the router is no longer reachable when this occurs.

What’s weird is the 2.4Ghz band continues to run and function normally. All my IoT devices on 2.4 continue working and my wireguard server keeps working.

to remotely fix the issue I’ve had to wireguard back to my 2.4 network and connect to my “keep connect” powerplug my router is plugged into and force the plug to reset. I have my Flint scheduled reboots every few days to try and prevent this but that hasn’t worked. Any Ideas?

Ill attach a few pics of how it looks on my side.

Pic shows can’t log into router through or through the app, says its offline, even second router attached to it says no internet, but all my 2.4ghz band IoT devices work.

can you share full system log?you can export it in SYSTEN->LOG
What firmware version are you using?

I can do that, but I can’t grab the log when the router locks up? Does getting it after I reset the router with a hard reset still work?

Current Firmware

  • Version4.2.1
  • Firmware Typerelease4
  • Compile Time2023-04-14 21:38:06(UTC+08:00)

logread.zip (24.4 KB)

Here’s a log if it still contains info you’re looking for

You mentioned that 2.4G is still available, can you log in to the device through 2.4G?
After you restart, logs other than the crash log will become meaningless.

I’ll try to log in from 2.4 I’m sure it will go funky some time today. Historically I couldn’t log in from good cloud or via wireguard remotely. But I’ll try to get logs when it locks up if it will let me.

1 Like

Alright the network went all jammed up again. The 2.4 devices all stayed connected and was able to live stream the security cams on that network still. I could not access the router in any way to download logs from it. I took as many screen shots as I could have various stuff in case it was helpful. I even tried hardwiring into the router. When hardwire the computer didn’t detect any connections and would not open the admin log-in IP. The good cloud website said the device was offline as well as the app.

Once again I was able to connect to devices on my network, from outside of it, using my wireguard app and trigger the router plug to reset. I took screen shots of this also. I finally ran out of options and rebooted the router, upon reconnecting I opened the log file. When looking at the log file I see all log recording stopped at 23:02 hrs on 05/21/23 when I finally rebooted the log I could see it resumed recording entries at 23:54hrs. All these images are in the following link also the same log mentioned is attached,

The screen shots have labels as well.

Another log file.
logread.zip (24.1 KB)

1 Like

Any possible ideas? This is a router I’m so close to just being in love with but the some of these major instabilities are becoming cumbersome.


Now you can only connect to the router through a serial port, which requires opening the router’s shell to connect.
If you are familiar with the connection method of serial port, we can debug the problem . After debugging, we will give you a new flint router.

It’d be kinda pain to set it all back up, but I’d rather fix the problem for others too. I don’t mind checking out the serial port debug for you. Just let me know what you need.

It’s also getting these large numbers of connect, disconnects.