Flint Router - DNS Server editing problem

I have a problem with the DNS server setting:
If I go to my Flint router under DNS server editing on manual setting and enter eg the Google/Cloadflare DNS server. Do I have then no more Internet access.

If I activate “DNS over TLS” the Cloadflare, then I have Internet connection, but under Internet - DNS Server - still the DNS addresses of the ISP are displayed. So the Cloadflare does not work then either ?

I have turned off AdGuard.
Wireguard Client is on.
Firmware: 3.214

What am I doing wrong or where is the problem ?

Hope someone can help me with the problem


If you confirm that the DNS you entered is correct but you cannot access the Internet, it is a bug. try resetting or upgrading to version 4.x.

The Internet page always shows the DNS from the interface. it does not mean that DoT is invalid. The manually set DNS has a higher priority.

Thanks for your answer.
Does SQM work on the new firmware version 4.x?

The luci-app-qos package should be available.