Flint v4.1.0 release3 - DDNS detect VPN IP

I have the mentioned Flint with 4.1.0 release3, configured an Open VPN client on it to connect to a VPN server. Also enabled DDNS but it detects the IP of the remote VPN server, not the router’s own external IP. It also says that local IP detected. “Services from GL.iNet don’t Use VPN” is turned on.

I won’t be able to upgrade the fw now to test it with the latest release unfortunately so I cannot confirm if this is still the same in those.

In the logs I can see this:

Detect local IP on 'web'
#> /usr/bin/curl -RsS -o /var/run/ddns/glddns.dat --stderr /var/run/ddns/glddns.err --noproxy '*' '[http://checkip.dyndns.com](http://checkip.dyndns.com/)'
Local IP 'REDACTED_VPN_SERVERS_PUBLIC_IP_HERE' detected on web at '[http://checkip.dyndns.com](http://checkip.dyndns.com/)'
Waiting 600 seconds (Check Interval)
Detect registered/public IP
#> /usr/bin/nslookup [REDACTED.glddns.com](http://redacted.glddns.com/) >/var/run/ddns/glddns.dat 2>/var/run/ddns/glddns.err

If I run the command I get the VPN server’s IP:

root@GL-AX1800:~# /usr/bin/curl -RsS --noproxy '*' '[http://checkip.dyndns.com](http://checkip.dyndns.com/)'
<html><head><title>Current IP Check</title></head><body>Current IP Address: REDACTED_VPN_SERVERS_PUBLIC_IP_HERE</body></html>

Can you try to check DNS resolution directly on the website? There are some bugs in the router’s built-in DDNS resolution check.

It may be just buggy.

Can you enable/disable “Services from GL.iNet don’t Use VPN” one more time and it may fix.

Please, upgrade to latest release (6) and then retry another time. There are a lot of changes since release 3.

1 Like