Flint - v4.4.6 - now it dies every night - not fking happy

I’ve had this Flint running for a few years, rock solid, WireGuard server, Adguard, 5G and 2G Wifi.

I add some more static hosts this year, add some more WiFi devices, an Amazon device, 7 Sonoff things.

Now this fkr is dying daily and repeatably… wtf

My first step will be to remove the static DHCP reservs (just reverse what I did)

Wifi is crap on these routers…

Reboot router, set auto channel WiFi. Your neighbour set up new WiFi with same number channel WiFi then your WiFi is conflict or no Internet…

1 Like

Thanks man, I already had her on auto channel. Couple of days ago I went in and took a look at the channels, and reset the “auto” as an experiment.

Still dies daily.

I’ve got the new little fucker latest Flint sitting next to her waiting to be powered up but after a week of my older “daily driver” Flint 1 dying I am pissed.

WiFi has always been flaky on these guys… I’m just venting.

So… what next… delete all my static DHCP reservations… up the cron log to try and see an error.

Grab one of my Mikrotik routers… I hate messing around with those things.

Static DHCP shouldn’t be borking your rig. logread -e netifd might turn up something quite relevant.


It’s a little late for it but for the next time you do so configuration:

1 Like

May you share the logs with us?

Daily “dying” seems to be curious. What does the log tell you when it’s time to die again?

1 Like

Thanks admon and bring.fringe18

I had set the logging cron level lower a few months back, to stop crap in the logs.

So I got nothing… when the router dies it does not allow any WiFi connects, and so I could not grab the logs. I will have to use an eth connected box to grab the logs next time.


Literally nothing has changed apart from me adding a few static DHCPs.

New tenants moved into the building, and I thought about them sitting on the same WiFi channel or even DeAuthing me… but the router becomes unreachable on both channels…


Could you try to set a static IP for your device when you connect to Wifi?
Maybe it’s not the whole router but “just” the DHCP server that dies.

1 Like

Not a bad idea. The WiFi becomes unreachable… on both channels it denies a connect. Weird. I thought maybe I have a new neighbor with a pwnagotchi or somebody playing… but no, it’s a hard unreachable on the WiFi side until a reboot.

Good idea about the DHCP server.

I will try clearing it all out, back to basics.


1 Like

Step 1.

Disabled AdGuard.

You’re off to a solid first step. Strip it all down to the core.

Hell, even reflash the latest stable firmware is recommendable; nuke it all. Then you can SSH in & get at the logs.

I fixed it by disabling AdGuard block lists.

The router has not had an issue since Dec 22nd.


1 Like