Flint wifi not recognized on devices

I have just received Flint today,
at first it seemed great, but unfortunately it looks like almost all the devices in my house, beside my laptop and smartphone cannot even see the wifi network. mostly It’s smart home devices trying to connect to the 2.4 network.
We are talking devices from multiple vendors with different purpose all having the same symptoms…
I tried disabling wifi 6 but it didn;t work.
Any ideas?

WPA3 only mode enabled ? but your devices can’t accept WPA3 authentication ?

No i’m using WPA2 for security

hmm…that’s strange, maybe manually change channels to see what happen.

tried all of them already :frowning: that’s super weird

Do you have the latest firmware? I think there is an update after the first batch.

Yes, I have the latest

The gl firmware dont ask by 1st configuration about your country. The wifi channels are different around the world, so theay are a small chnce you don’t get any wifi connect by this misconfiguration.

You can setup your country and on advanced web interface menu.

The bug are already on the user driven bug list:

2.4Ghz channels can’t go too wrong in any Wi-Fi country code configuration except Japan which has channels 12,13 and14 and the devices can’t even see the SSID.

Another possible cause might be the Wi-Fi 2.4Ghz configuration is set in 40Mhz (2 channels combined), the smart home devices can’t connect to it due to compatibility issue.

Some country’s have the 11, 12 and 13 too, perhaps all EU country’s …

This misconfiguration is known and reported since some time on some user driven bug lists. The actual bug list are the follow:

Perhaps the combination of WPA2 and WPA3 mode, which are available on advanced admin mode, and perhaps not available on easy web interface, are one alternate which give a better performance and the feeling of a little better security.

I also have lots of issues with 2G wifi on Flint. 90% of my 2.4Ghz devices, 13 devices total, does not want to connect, it is stuck at associating. Only 3 devices connect.

5G works fine, all 6 devices connect without problems.

Any idea I could try, or should I just send router back?

Any news on that matter?
It pretty much makes the router useless…

The problem is fixed. Will send out firmware tomorrow.

Thanks @alzhao !
Where can it be downloaded from? Can’t find it on the firmware download page on the website (or any Flint firmware actually)

Try this https://dl.gl-inet.com/firmware/ax1800/testing/