Flint with AdGuardHome + Unbound DNS on Pi

Hi all,

How do I configure my AX1800 Flint with AdGuardHome (192.168.1.1) to use the recursive Unbound DNS running on my RasPi2 with Pi-hole (192.168.1.5) as my upstream DNS, and just use AdGuardHome as DNS proxy for content filtering. At the moment I’ve replaced the below

tls://dns.adguard-dns.com
https://dns.adguard-dns.com/dns-query

with 192.168.1.5 as seen in the attached screenshot, not sure though if this configuration is working.

Yup, should work like that.

Make sure to enforce AGH for all devices.
It’s not even necessary to use AGH. You can simply specify a new DNS within the DNS settings of the router itself.

AGH will just take up resources.

Does not work actually, clients unable to resolve DNS requests when 192.168.1.5 is set as upstream, even the router itself is unable to resolve host names although pinging an ip address e.g., 1.1.1.1 works. I have disabled AGH and set the router’s DNS settings to manual and set it to 192.168.1.5, internet now works but this setup is not what I intended. Ad blocking seems to be spotty at best, and I am not sure if Pihole’s adlist really works as expected because clients can now access porn whereas before they could not with AGH. Moreover internet connection would suddenly stop because of temporary failure in name resolution per Pihole logs, and for the meantime I’ve enabled AGH again until the intended setup works.