Flint2 DLNA shares not working but samba does

So ever since getting the router I’ve had no issue with SMB working no trouble. Unfortunately, the dlna sharing hasnt worked at all. I set it all correctly and it says its enabled, but its not. Its running the up to date firmware. The DLNA share pops up and you can “view it” but none of the media files are actually accessible. I can only access the media files over samba. Anyone know why this is and if there is a fix for it?

Hi, could you please provide me with your specific operating steps so that I can test it correctly here? Thank you

Yes, and I will include a couple screen shots to show you where I have both the samba share and the DLNA share included at. Also I would assume since even on one of my old everyday consumer routers you could do both smb&dlna at the same time it shouldnt matter if I am using samba AND DLNA from the same exact folder because any other device and server could serve them up no problem. This must just be a bug because it shows up in broadcasts to my entire network but there are NO folders to browse other than the category music photos videos and browse all and no natter which it says there are no folders to view. I would truly like to fix this, but even disabling samba and using dlna only including on any folder (even moved them around to new folders, reformatted, tried a seconday drive and it simply did not matter. I was hoping some of the changes I’ve tried would work but none of these changes have been able to make any files, no matter which type actually be accessible by any device in my network unless its through samba only. I am pretty convinced this is a bug because I’ve never had any issues running both smb and dlna from the same folder at the same time on various devices, servers, routers, etc. Please let me know how I can get the dlna working because nothing I can do so far works. Would in the mean time using a package on the luci side for dlna maybe bypass this bug until a fix comes out for it?

as you can see from the two screen shots, I have the smb share running from the same location as the dlna share.

***One last question I have to get around the fact it doesn’t let me configure my workgroup at all (please add the workgroup to the UI, that would be so much simpler)

seeing as I dont use the default workgroup, I want to change it so all my other services (and the one I use personally on my network) will be in the same one. Where do I go at in the filesystem and modify which configuration file to change the workgroup? I tried editing one file I thought (lol not like any smb conf ive ever seen but I tried) and it DEFINITELY ignores the change I made lol. I really would like this to be able to be set but I am comfortable in a terminal, I just have no frickin clue where, these newer glinet versions are FAR different from older versions with more similarities to plain openwrt. any advice there would be vey appreciated as well.


  1. To use DLNA, you need to download the VLC app on your phone. Here is the link: https://images.videolan.org/ . First, connect your phone to the Wi-Fi of your router. Then, open the DLNA feature on your router. After that, open the VLC app and click on the browse icon at the bottom center. Go to the “Local Network” section and select your device. The name should be your router’s name + DLNA + Server, represented by a small penguin icon. Click on it to access DLNA. Because I can only download the Chinese version here, the text in the images is in Chinese.

  2. The configuration file for the Samba workgroup on the router is located in /etc/config/samba4. Since only this file contains the workgroup configuration, I’m not sure if it’s the one you need. If it’s not, could you please briefly explain what you intend to do with the workgroup configuration file? This will allow me to help you find the specific file you need.

1 Like

What is default version samba in flint 2? Sometime vlc has setting with smb

Disable SMBv1 for sure. It’s totally unsafe and dead.
Normal version should be SMB3 (or at least SMB2)

1 Like

Hi, the SMB version on Flint 2 is SMB4.

1 Like