Flint2 dynamic dns fix (NOIP workaround)

Managed to get dynamic DNS working for NOIP, requires config in Luci and breaks the the Dynamic DNS config in the “standard web gui”.

Remove gl-sdk4-ddns

This breaks the Dynamic DNS in the standard GUI, but can be done via Luci (or command line)

Remove ddns related packages

Removing these may not be strictly necessary, but I wanted to clear any gunk

update package list
install luci-app-ddns
install ddns-scripts
install ddns-scripts-services

install ddns-scripts-noip

Another thread for cloudflare from earlier in 2024 said they had to download versions manually from openwrt, I was fine with the versions coming down from within the included luci getting packages from glinet. The versions that came down for ddns-scripts/services are 2.8.2-43, and noip scripts were 2.8.2-12.

After that it sems to work with No-IP and gl-inet dynamic DNS. Tested by moving it’s connection back and forth between the ISP, and tethering between a couple of phones on different 5G networks.

When will the official gl-inet module be fixed so that Dynamic DNS can be configured in a friendly way for providers other than gl-inet? (and more importantly so it doesn’t bork other ddns services?)

You should just install


Also don’t forget to enable glddns service because this controls the global enable/disable option.