Flint2 - slow wifi

Model: GLMT6000
AX6000 wireless router.
Firmware: 4.5.6 release 1
Kernel version: 5.15.139
Open wrt version: OpenWrt 23.05-SNAPSHOT r23001+721-38c150612c

Brand new router and got it yesterday. Router is directly connected to the FIOS WAN.
5GHz Wifi download speed is 83Mbps and upload speed is 86Mbps, compared to default FIOS router which gives download 449 Mbps and upload 243 Mbps. Extremely disappointed with this performance.

So far I have tried changing Bandwidth to 160 MHz with no luck, also changed wifi mode to 11a/n/ac with not much success. With 160MHz got download speed of 258 Mbps and upload speed of 39 Mbps.

Are there any tweaks to make this better? Really don’t want to return this back.

Thanks

The equipment has been showing a lot of instability and Wi-Fi has not been optimized so far.

You can get more details by following thred!

Flint 2 (GL-MT6000 ) - bug reports - collective thread - Technical Support for Routers - GL.iNet (gl-inet.com)

1 Like

Thank you for the quick response.
I also got a GL-AXT1800 (mainly for travel) and that is giving Download 350 Mbps and upload 242 Mbps out of box. Very impressive for such a small router.

Would you recommend any other wireless router to mainly act as VPN server at home? Budget is not a concern. Just need better wifi performance and vpn speeds. Thanks again.

Unfortunately, I don’t think I can say the model of the router here. However for a VPN solution, I would look at an RPI-5, the performance with Wireguard running with OpenWRT on it is absurd, surpassing even commercial equipment from Fortinet, Cisco, Palo Alto CheckPoint at this point!

1 Like

I would highly recommend an Asus router that supports Merlin’s firmware on it. Mine runs as solid as rock.

1 Like

Thank you, GT-AX6000 seems very impressive. Also seems to support Merlin 3004.388.6_2
I also looked at RPI-5 and I’m afraid it has steep learning curve for someone with not much networking knowledge. I would still get one and play with it at leisure. For immediate needs, hopefully GT-AX6000 will serve well.

1 Like

GT-AX6000 is exactly the model I am using just now.

1 Like
  1. Try the Beta firmware. The latest changelog says they worked on improving the WiFi network
    GL.iNet download center

  2. Do not connect any USB 3.0 device on the USB port. I have bad experience when doing this due to the high interference on the 2.4GHz network.

Try the 4.5.7 beta firmware, which is using closed source MediaTek wireless drivers. It performs much better for me and others, especially where WiFi is concerned. The downside is it’s based off an old version of OpenWrt and many packages are not working. Personally, in the short term it will suffice, as I now have performant WiFi and do not receive complaints from the family.

Upgraded to 4.5.7 beta firmware, and the download speed did improve. It is 331Mbps compared to 83Mbps out of the box on 5GHz. However, upload speed got worse it is 50.45 Mbps compared to 86Mbps out of the box. (With ISP vendor router download was at 449 Mbps and upload at 243 Mbps.)

Thanks for the all the help being provided.

Perhaps you did this, but if not it might be worth to try a factory reset, since 4.5.7 is not a straight upgrade per se, and OpenWrt used is 21.02 instead of 23.05.

I tried again last night and did a factory reset and went to 4.5.7 beta firmware, still no luck. I will return this router. Thank again for all the help.

1 Like