Force reconnection in Repeater Mode

Hello all.

I have a GL-MT3000 (Beryl AX) and firmware was updated last week to latest version.

I’m on a cruise ship (Carnival Mardi Gras). The travel router connected to the wifi in repeater mode no problem. [I used the first time I connected any devices to the network, so it would have been the first MAC address the network saw - I read some people might have an issue with this, so I wanted to point this out].

However, it keeps randomly disconnecting - typically when nobody’s been on it for a bit. Is there any way to force it to reconnect? (b/c it doesn’t)

Or to force a small amount of traffic through the router so that the ship’s network doesn’t think that the router is a ‘stale’ connection and terminate it? [not sure if this is actually the issue or not]

Thanks!

The logic of the current repeater design is to automatically reconnect and It will stop reconnecting unless the repeater connection shows an incorrect password. what are the prompts on the ui?

If goodcloud is turned on, a small amount of traffic will always pass through.

I thought that mwan3 would already be sending out repetitive pings to detect Internet accessibility, which should be a small amount of traffic.

I do not work for and I am not directly associated with GL.iNet

Hi, is there a way to let the router keep scanning forever?
I am using a SFT1200 to connect to a wifi camera locally and occasionally I enable the hotspot in my mobile phone.
I thought the router would be able to work in this scenario but like you say it stop trying to reconnect after a while.
It could pass days between each time the hotspot is enabled, is there a way to workaround this?
I have setup the router for some people who doesn’t understand anything about tech at all, I cannot ask them to go to the web interface to reconnect every time.

Could you provide some logs about the time when it stops to reconnect?

I solved it, by updating to the latest 4.x beta firmware. It seem 3.x firmware have a different behaviour for reconnection, once it gives up it never reconnect automatically.