FTP default port not working on AXT1800 for NAS


I try sharing my WD My Cloud EX2 NAS on WAN with my AXT1800


  • Forwarding port 80 on WAN works.
  • Port 21 appears open on WAN.
  • FTP works on LAN.
  • FTP passive ports forwarded also.
  • If I changing the default FTP port on NAS to a custom unassigned port, it works.
  • Changing the FTP port to 4455 will make OVPN server not connectable.

If you are using Luci, I would normally put these under traffic rules rather than port forward, as you want to allow access to the device not make the device “forward” to another device.


I’d be more than happy to have it fully working so I can give my friends and family recommandations to buy a simple to use router. I can make it work somehow, but it would be nice if they can fix this.

Not very clear about the topology and settings. Will these packages be helpful?

opkg update
opkg install kmod-nf-nathelper
opkg install kmod-nf-nathelper-extra