Gateway behind Wireguard GW

Hi Everybody,
i need help please and tried a lot before i wrote this post.
I bought 2 MT-2500 to make a site to site connection. I got that running as discribed here in the Router Docs → here
BUT: behind my Wireguard gateway is another gateway which ist providing access to a second network. All connected devices should be connected to each other.
see the picture from the tutorial above please. on the left side from the wg server is in my case a gateway to another network, i am not able to access from that network into the tunnel an connected devices. All devices can ping to the LAN Port of the WG Gateway but not from one end to the other. Is that possible and when yes, how?

Brume2 WG Gateway connected to WAN Port
LAN: → (Gateway to the second network with the routes) e.g.->
Virtual IPs /24

Brume2 WG Client connected to WAN Port

Devices from 10.70.9.x can ping to and Wiregard Clients but not to the Gateway IP

May it is a configuration in advanced settings and LAN bridge?

Thank you so much for your help

I am not so clear about your topology and problem/needing. Is your topology looks like piture below? And you can ping PC1 and WG-client2 from PC2, but cannot ping Brume2-A’s gateway(

Pings within the circles are working.
Ping from to > ok
Ping from to > not ok
Ping from to > ok
Ping from to > not ok

Thank you.

About Ping from to > not ok, it maybe a firewall issue of Gateway.In my case, I have to run iptables -I INPUT -i eth0 -p icmp -j ACCEPT on Gateway to allow incoming icmp packet.

And about Ping from to > not ok, please change LAN netmask of both Brume2 to below). And could you try with the lastest beta version GL.iNet download center? If you donnot want to upgrade, you can run ifup wgserver on Brume2-A after you done with route rule setting(piture2 below). And then make sure LAN subnet of Brume2-B has been added to WG server’s allowed ips, which can be checked by command wg and ip route(picture3 below).Finally, running “ifup wgclient” or restart wgclient on Admin Panel for quick reconnection.


i tried that but no connection

  1. updated firmware to beta
  2. icmp allowed as discribed
  3. Netmasks were allready at /24
    4.routes are configured, i compared that with the screenshots

If i go to advanced > luci > network diagnostics > Ping, the ping is ok, from the tunnel not
I think the point is, that the 12.253 is not reachable, so the routes doesnt work.
DHCP is completly off for lan. Whats about the default Gateway? if i put 12.253 in there, tunnels cannot connect annymore.

Could you share your device to gl.inet_support? I want to log in to your device and have a remote check.

Where can i find this option in my mt2500?

I have pm you a document, please refer to that guide to share your device with us for remote troubleshooting.Thanks a lot

After remote check, I found that ping from WG server to gateway is ok, but ping from WG client to gateway is not ok. Ping from WGclient have been forwarded to gateway, but didn’t get response from gateway.It seems like ping from wgclient is rejected/blocked by gateway.Could you capture packets on gateway for further check?


You can also connect a PC directly to WG server, and use wireshark to capture packets on PC. If you can capture icmp request from wgclient on PC, then route rule settings are without problem.