Geolocation on laptop?

Really struggling to set this up. Currently have a flint set up and with a beryl for traveling. Its working fine, IP shows as where flint is set up through wireguard. Laptop is connected via ethernet, I have wifi and bluetooth off, just cant turn off location services, in airplane mode, but using google maps on firefox or chrome still shows somewhat accurate of a location? Using browserleaks also shows my geolocation. I have geolocation turned off in my browsers, but my question is, why does my geolocation still show despite it being on a wired connection?

Isn’t this a laptop question in a router forum?

I think the problem is the laptop because neither of those routers have GPS settings.

The answer to the question is that you can always be found by ping and traceroute. Each node has a geolocation so it’s not hard to get a rough location of any ip on the Internet, with or without VPN.

It is your computer or phone’s Geolocation sold you out.

You can also check out this post GL-SFT1200 w/ OpenVPN + TorGuard - incorrect IP adress in Office365/Teams - #4 by ChrisP

1 Like

Well, I actually tried connecting to another wireguard server at a different location. The geolocation when I looked it up was showing up correctly at where that other server was set up. The IP address is correct for both servers, just the first server is showing the wrong geolocation. Any ideas why this is happening?

may be DNS leaking in the other wireguard profile

any leaks will give out your true location. The purpose of a VPN is to avoid those, if properly configured. Phones that are tied to our accounts can give out location too – which is normally the first thing people tend to ignore.

1 Like

I guess I will try to reconfigure the server. Do you have any experience using okta or any authentication apps on a phone? Say if I am pressing yes its me or whatever on the phone not connected to the vpn, this would give away the location to my laptop thats connected to the vpn?

I work with Okta, the location displayed when you get the push notification is from your computer. I’m not an Okta admin, so not sure if the app gives out your location or not – you could change the authentication method to an OTP instead of push

When I’m abroad, Okta just asks to tap yes and the location is from my computer’s VPN so no leak there. Teams might be different though.

Since Okta doesn’t ask for location permissions, you could connect your phone to the VPN, disable cellular networks and accept the push. Might not make any difference, but it’s worth a try.

Got it thank you. That’s strange, then the issue definitely is with the server. It worked before but suddenly started showing my actual location… I set up the second server using the same method and no leaks there.

Then there you go, use the second server, and try to reset the first one (ie: set it up the same way) so you have a backup? not sure I’m following but having one server is better than none :slight_smile: