GL-A1300 - AdGuard not able to add/update blocklists

Running AdGuard on my travelrouter GL-A1300 gives issues since the last firmware update to version 4.5.16.

Adguard is running but not loading the default AdGuard DNS filter list. Count stays at “0”. Also adding a new blocklist, does not work. I get a time out error in the right corner.

Resetting device to factory settings, enabling just AdGuard does not fix the issue. Still not able to update/add blocklists…

Or is it just not enough power;

|CPU|IPQ4018, Quad Core@717MHz|
|Memory / Storage|DDR3L 256MB / NOR Flash 4MB + NAND Flash 128MB|

No one? The GL-1300 is advertised with AdGuard, so it should run properly.

Why I can’t even update the stock blocklist without issues?

My MT-2500 has no issues at all.

Did you already upgrade to newest AGH version?

Which is the latest one for these routers? I don’t see any updates pending. Running AdGuard v0.107.26

I’ve already updated the router to the latest firmware to 4.5.16 rel2.

I’m not that familiar with SSH. Just running commands I can, but this is something you created for GL.Inet? Or why are these routers not updated to the latest AdGuard version?

It’s just running, so it’s easier.

Yep, I created that for the community because the firmware does not contain the newest AGH version. That’s because AGH is a 3rd-party-plugin and you would need to build the fw every time they push some update.

I can’t promise that updating AGH will solve your problem, but it’s worth a try.

Okay thank you. Will support from GL.Inet main intact?

I’m just curious if others who have also the GL-A1300, experience the same issues running AdGuard on their devices.

Same here on same device , i see message Error: control/filtering/refresh | Network Error In the corner

I also tried the update script, however have the same issue

Yes it’s the same for me. Only when you use smaller blocklist, sometimes they update without issues.

Would be nice if the GL.Inet staff joins the discussion to clear this up;

  • is the device powerful enough?
  • if yes, why does AdGuard stock config not work as designed then?
  • if no, why you advertise with AdGuard on this GL-A1300 if it’s not powerful enough?

Depend how many filters you want to block.
My suggestion put upstream adguard dns server for free. Inside account you can add filters.

If not enough space ram or storage, try restart router :thinking:

Uuuh… even the default blocklist doesn’t load… Adding more filters is step 2.

You can also set as default DNS and not use AdGuard on your router but that’s not a solution for the problem.

That one you can set adguard dns address I shared a link above.
Don’t confuse Adguard Home and Adguard DNS.

Here my list adguard DNS which I used upstream in my Adguard Home travel router

Yes, same solution right? You don’t run it local. Filtering takes place remotely, instead of local on the router.

I understand that this can be a workaround, but I want to filter locally instead of sending all traffic remotely.

You can also set your DNS server at home and setup a VPN connection from the travel router, but it should work on the GL-A1300 itself if you sell it out of the box with AdGuard…

Both I use. Upstream for Adguard DNS with basic available filters. Local added more list filters plus manual list filters.Total many many rules filtered :sunglasses:

I don’t want use the public DNS resolver which website I visited. So I used private Adguard DNS resolver.

On which GL.Inet router? Because thats the main issue with the GL-A1300. It will not load local added filterlists…

Same problem on the same router.