GL-A1300 Slate Plus VPN issue with firmware 4.2

After upgrading firmware to 4.2 I have two annoying issues.

  1. Turning on the VPN (openwrt) shows the status connected but I’m not able to reach any internet sites. I never had problems with firmware 4.1.2. As soon as I turn vpn off, everything works fine.
  2. As soon as I trun parental control on, the hardware switch doesn’t work anymore. No problems with 4.1.2 so far. I set the switch this way up to activate/de-activate the vpn.

Second issue is not that problem but not being able to use the vpn at all is not acceptable.

Anyone with the same issues?

How can I downgrade to 4.1.2 if there is no solution available soon? I need to have vpn activated on the 1300.

Thanks for any help

P.S.: I already rebooted the router but without any luck.

What is the DNS settings?
Is DNS Rebinding Attack Protection enabled?
Is Override DNS Settings for All Clients enabled?
What are the Global host settings?

What are the Global options settings in the VPN Dashboard?

2.) The switch diagram is actual backwards when you think it is on it is off(not sure if it was fixed yet) their is a post about it.

That may be you issue

DNS Server settings: Automatic
DNS Rebinding Attack Protection: off
Override DNS Settings for All Clients: off

VPN Gloabl Options:
Block Non-VPN Traffic: off
Allow Access WAN: off
Services from GL.iNet Use VPN: on

As I wrote, the VPN established and the connections works for a couple of seconds but after the first 3 seconds it stops working.

Do you mean the parental control switch works backwords on is off and off is on? But even so, why ist the hardware switch not working anymore as soon as parental control is activated. And is doing nothing even not in the wrong direction.

Please let me know if more information is needed


What VPN service are you using?
Does the VPN config file contain upstream DNS to use?
Are you using Ipv6 of ipv4?(most vpns can only use ipv4)

Does you VPN service offer DNS servers to use, usually you want to have it use them to avoid leaks.

The physical toggle switch on the side of the router is what i am referring to.

Parental control is a new feature may have a bug. No documents yet on it

Are you using OpenVPN? there is a bug with keeping setting sysupgrade.

@hansome: Yes I’m using OpenVPN. Do you have an ETA for a fix? Should I wait or downgrade to 4.1.2 which worked very well for me and wait until a fix is implemented?


@K3rn3l_Ku5h I’m using ExpressVPN via OpenVPN and I’m using ipv4. Honestlay I don’t know if the VPN config file contains upstream DNS to use. I used the settings and config file with firmware 4.1.2 and all worked very well. I haven’t changed anything but upgrading the router.

I advise you to keep using 4.2 version by doing a factory reset and setup OpenVPN client again.
This week 4.2.1 will be released to address this issue.

@hansome Thanks for your advise. I did a factory reset and setup the router from scratch. Now the VPN seems to work fine again. There is still the hiccup with the not working hardware switch if parental control is turned on. But I can wait for a fix for that. VPN is more important to me. Waiting for the new firmware revision you mentioned in your post.

Thanks so far.

1 Like

Thank you, we’ll test and fix this bug.

1 Like

@hansome I saw there is a new beta (4.2.1 relase 2) flying around. Can you recommend to install and try it out or should I better wait for the stable relase and how long do you think will it take to get a stable revisison. Can spend some information what’s got fixed in the new beta?


Yes, this release has addressed the two issues you mentioned. Recommend installing.

Other updates(copy the release note):


Bug Fixes

  • Fixed a problem where the WiFi configuration page showed unavailable channel options.
  • Fixed a problem where NordVPN could not resolve DNS after keeping settings upgrade.
  • Fixed a problem where GL-MT3000 failed to recognize USB3.0 modem.
  • Fixed a problem where the IPV6 rate limiting does not take effect.
  • Fixed a problem where GL-MT3000 failed to repeat to iPhone 13 and TP-LINK ACR700.
  • Fixed a memory leak problem in GL-MT3000 when using QCM protocol.
  • Fixed a probabilistic issue where GL-MT3000 could not apply OpenVPN username and password.
  • Fixed switch button not taking effect when parental control is enabled on GL-A1300.


  • Disabled nginx access logs.
  • Optimized the MWAN3 online detection threshold.
  • Optimized the synchronization of configuration files in abnormal situations.
  • Optimized the repeater scan time of GL-MT3000.

Software Upgrade

  • Upgraded AdguardHome to V0.107.26.
1 Like

Just installed beta firmware 4.2.1 and all seems to work fine. Thanks a lot so far.

@hansome The router was working as expected until yesterday. Now I’m traveling and need the router and now it fails totally.

  • Out of the sudden the router WiFi network wasn’t available anymore. Not shown in the list of available networks
  • Wasn’t able to login even with cable
  • Reset the entire router and had trouble to connect back to the router even using network cable
  • After some time I was able to get back in the router setup
  • The router WiFi is very unstable and is more gone than available. 5G is shown very unreliable, 2.4 isn’t shown at all.
  • If I try to connct the repeater with the WiFi source no /and really no of the existing WiFi networks is shown in the list.

Currently the router is the totally useless. Is it a software problem which can be fixed or is it a hardware issue and I have to send it back?

Please advise

P.S.: Still using 4.2.1 release 2 beta

Sorry to cause you trouble. Is it stable with version 4.1.2?
Could you generate a configuration backup for our analysis at luci page and send it to

I would like to know the combination of functions you are using. Please allow me to check and determine whether the issue is related to hardware or software.

@hansome any updates in this regard?
Sent you the requested data last week.

I also resetted the router to factory settings again. Still with 4.2.1 R2. Now I see other WiFi networks again. Since it’s always a bit time consuming to set up the entire router or to flash 5he latest stable revision I haven’t done so far.

Do you have any advise or new findings what’s the issue?


Thank you for providing the backup file. I have reviewed it and found no special settings.

However, I discovered that version 4.2.1 has a bug related to setting the WiFi channel. This causes problems with both the WiFi and the repeater, indicating a software issue. Regarding the cable issue you mentioned, we need more time to test and observe, but it more likely is a software issue related to high system load.

I recommend using firmware version 4.2.0 stable (without keep-setting) for now. When version 4.2.1 becomes stable enough, I will inform you.

1 Like

Can I flash 4.2 stable using the usual admin config page or need I to use luci page?


Usual admin config page will be okay without keep setting when downgrading.

@hansome does that apply to the GL-MT3000 as well?
Asking because my wifi repeater is super unpredictable and drops connections intermitently (see my latest post on the tech support channel), so I’m wondering if there’s an undelying major sw issue causing several wifi issues reported by me and many other folks?

1 Like