GL AR 300M for remote serial console access to Cisco routers

Hi, I am new here. I just bought my AR 300M mini router recently. Now I am wondering if I can use it to remotely access the console ports for Cisco routers. Cisco router console port require a serial connection, normally with a RJ45 to DB9 console cable or a RJ45 rollover cable and a RJ45-DB9 adaptor.

I think AR 300M has a USB 2.0 port, as well as serial pins inside the box, is it right?

Does the USB 2.0 port support USB to serial (RS232 DB9) adaptors? Is the driver built in or do I need to install it? Any specific adapter chips supported (FTDI or Silabs for processor, Maxim, Exar or NI for serial driver)?

Or is it easier to use serial pins? I suppose I need to DIY a cable, either 3-pin to RJ45 or 3-pin to DB9, is it possible?

Would one or both of these solutions work? Any additional software/driver do I need to install to AR300M. What setting do I need and how to I connect to the serial console from AR300M if I telnet into AR300M?

Thanks a lot!

AR300M has some built-in driver of USB uart adapters, for example this one:

When plugged into the USB port it will create a device as /dev/ttyUSB0

Yes, you can use serial pins. But there is a lot info will be printed to the serial console by default. This may case a trouble to you.

I don’t have a Cisco routers so I cannot confirm it 100% works.

For AR300M, the serial device is /dev/ttyS0. You can just echo or cat this device.

Does this adapter replace the need to solder in the AR300M?

I did some more reading, and now I understand the problem better. What Cisco console port need is a RS-232 serial connection. So UART signal needs to be converted to RS-232 with a RS-232 driver chip (such as Maxim, Exar or NI). But it might be easier to just use an USB to RS-232 (DB9 or RJ45) adapter cable, such as these two:

They both use FTDI chip for UART. So the question is: is FTDI chip supported? What is the chip inside the UART adapter CP2104?


@Glitch, the adapter can be just plugged into the USB-A of the mini router and works.

@kzqc, I used to have FTDI chip USB uart adapter. Now we choose CP2104. Basically they are of the same function. So I suppose this will work.

FTDI chip is not supported in the stock firmware. But I think you can add kernel driver to make it work, although I don’t know which one.

CP2104 is the chipset. It is a good one.


So I googled, CP2104 is a Silicon Labs chipset, another good UART manufacturer. I just need to find a USB to RS232 cable with SiLabs chipset, I guess it will be supported with built in driver. However, there is almost no USB to RS232 adapter/cable with Silicon Labs chipset available on the web. There are lots of USB to UART ones with SiLabs chipset just like the one GL-Inet has.

So probably I still need to use FTDI cables.

FTDI drivers are here: (not sure if I need the VCP driver which is not available for ARM)

I suppose I should use the one marked for Raspberry Pi, right? How do I install it? Sorry that I am not familiar with Linux. After I install it, would I also have /dev/ttyUSB0?

Finally, does the stock firmware support any other chipset? How about the Prolific chipset (cheaper and not as good as FTDI and SiLabs, but widely available)?

Thanks a lot.

just install kmod-usb-serial-ftdi and reboot it works with FTDI adapters.

You would be better served by a v92 dial modem. They already have serial ports and if your broadband is down you can dial in to see what’s wrong.

I got the following error when trying to install kmod-usb-serial-ftdi

root@GL1:~# opkg install kmod-usb-serial kmod-usb-serial-ftdi
Package kmod-usb-serial (3.18.27-1) installed in root is up to date.
Installing kmod-usb-serial-ftdi (3.18.27-1) to root…
Downloading 404 Page not found - GL.iNet.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-serial-ftdi:
  •  kernel (= 3.18.27-1-e5ed52b8a26964473b4e4d079fbf6f41) *
  • opkg_install_cmd: Cannot install package kmod-usb-serial-ftdi.


could you elaborate how it works wtih v92 dial modem? My goal is to access the Cisco serial console port. With FTDI USB to RS232 cable, AR300M can talk to Cisco console port through the /dev/ttyUSB0 as a serial port. I just need to install a serial terminal software such as minicom (any other such apps?) and then I can login to Cisco router console port.

I needed this so that I can access Cisco router console port over wifi from next room. I don’t want to use a 50 feet long RJ45 rollover cable for a wired connection.

I found some other solutions for my purpose here, including Bluetooth serial adapters or wifi to serial adapters:

But I already have AR300M and I like to try this first before I try other ones.

I don’t have a telephone line at every Cisco router in every customer site I will be visiting, so I am not sure how V92 modem will work here. Could you please clarify? Thanks.


Any idea why I get the error when installing the FTDI driver? How can I resolve it? thanks.

@kzqc, this is strange. All our firmware and soft repo is compiled at the same time so there should no such issues.

From your log you are using Nor firmware. Can you pls check check which version are you using in the UI. You will find this in the bottom part of the UI.

If you ever modified the opkg.conf and upgrade from an older version, you many need to reset the firmware.

I have the latest firmware 2.25, and I think I am using NAND, since I did not change anything to make it boot from NOR, and on the bottom of the page, it shows model as ar300m NAND. I never changed opkg.conf. I may or may not have updated the firmware after I bought it.


I recently utilized an RPi2 as a serial console connected to a few Cisco router (s) in a server room from my desktops (W7 and Ubuntu). Worked just fine.

The above noted I also utilize another microrouter (a bit smaller than the Gli-Net AR300M) as a combo firewall, serial console, wired or wireless connection and out of band management for my alarm/automation panel (Leviton Omni-Pro 2). (connect to it via LAN / Serial port - USB).

Just SSH to the AR300M and use minicom or install SerToNet or open a local serial console or use Putty from windows…

You could also build a little out of band management box using VPN and a USB cellular modem stick.

Have a small stack of Cisco routers here somewhere in the basement…will give it a try with the Gli-Net AR300M.


Found a generic USB to serial cable, Cisco console cable and an old Cisco router.

Installed minicom and picocom. Using minicom. Connected to AR 300M via wireless / SSH


ssh root@
root@’s password:
BusyBox v1.24.1 (2016-08-26 18:45:39 HKT) built-in shell (ash)

| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || |
_____|| |
||||___||| |____|
| W I R E L E S S F R E E D O M

CHAOS CALMER (Chaos Calmer, r47065)

  • 1 1/2 oz Gin Shake with a glassful
  • 1/4 oz Triple Sec of broken ice and pour
  • 3/4 oz Lime Juice unstrained into a goblet.
  • 1 1/2 oz Orange Juice
  • 1 tsp. Grenadine Syrup

root@ICS-1:/dev# ls ttyU*

root@ICS-1:~# minicom

GliNetTesting>show version
Cisco Internetwork Operating System Software
IOS ™ C2600 Software (C2600-IS-M), Version 12.0(7)T, RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 07-Dec-99 02:21 by phanguye
Image text-base: 0x80008088, data-base: 0x80C524F8

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Just noticed set time to America/Chicago and it seems not to have worked as it is showing HKT.


Thanks for sharing your experience and also testing it again. It helped a lot.

After resetting the AR300M firmware to factory and reconfig, I was able to install both the FTDI and prolific (pl2303) drivers as well as minicom. I was able to successfully connect to cisco switches. Everything was good except that I don’t like minicom since it messes up the putty log file. I hope the SerToNet you mentioned is better in this regard.

About SerToNet, is it Ser2Net? Since I was not able to find SerToNet software. The Ser2Net software seems to be linux only, so I guess I need to install it on the AR300M. Do you know how to install it, or is there a website with more information on this? Thanks.

BTW, I also bought the Blutronium Bluetooth to Serial adapter from USConverters. The bluetooth adapter is still more convenient (with built-in battery) and easier to use, also allows the wifi to be used for internet during the work. It is more suited for situations where you need to move a lot between racks and closets. Wifi solution such as AR300M and RPi is more flexible, and cheaper, and is more suited for more stable environment.

Better than ser2net is comserver.

Read about it here:

Install it from here:

I have asked the author how to install his customized for OpenWRT comserver.



Thanks a lot. It sounds great. Although I am still not clear how to install conserver. Sorry my unix/linux knowledge is from 10 years ago, so I am not familiar with the new packaging/installation schemes of linux nowadays. I understand the official installation documentation is using make to compile and install the software on unix/linux. But I doubt that make can compile this on the AR300M router. So if you have more info on how to install conserver or ser2net on OpenWRT or AR300M, please help. Thanks again.