GL-AR150 Channel 13 needed for upstream router (WISP)

Hello Everyone,

I have just gotten a GL-AR150 and would like to set it up in WISP mode.

My upstream router uses channel 13 (I cannot change that router; it’s an ISP’s city WIFI router). I can connect to it via my PC, my phones, and iPad, but not the GL-AR150.

Note: I am in Asia; router received via

As it looks, on my GL-AR150 I cannot select channel 13. How can I upgrade it, so I can use channel 13 as well? I know, in the US channel 13 is not permitted, but here it is used.

Thank you so much for taking the time.



Hello Haifu,


I did Google a bit and found a patch that could allow you to use channel 12 and 13.

You will have to enter this command:

  • iw reg set DE

Note: DE stands for Germany, you could also enter your own. But it won’t make a big difference as most countries allow 12 and 13.


I hope that this fixes your problem.

Hi Hiero,

thanks a lot for your reply and taking the time. The company replied to my issue. Setting the correct region, followed by a firmware update to 2.20 solved the problem for me. I can now connect to the upstream router. Have a great day.


glad it works for you.