GL-AR150, GL-AR750: WireGuard Client cannot connect to a GLiNet WireGuard server

I have two routers, GL-AR150 and GL-AR750.
I’m trying to setup a WireGuard client on one and connect to the server on the other.

To start, I created a server on GL-AR750. I can connect to it with my phone seamlessly. However, I cannot connect to the server through GL-AR150 WireGuard client (copying either plain text or json configuration over).

For this test I connected one router to the internet via WAN and the other one via tethering. I verified both have internet access. Swapping the connection method didn’t help.

I also switched the server/client devices (using GL-AR750 as client and GL-AR150 as server) but still seeing the same issue. Also made sure the endpoints (or DDNS if used) are correct and accessible.

Happy to share screenshots of the configs I’m using.

Do you have dynamic white IP’s? Or static IP on first router?

It’s dynamic IP on the first router. I can access the IP (or the DDNS mapping) through my phone’s internet and wireguard app.

Do you try default reset routers and made new configuration? On the connecting info first page in router GUI the same IP as the

Your phone connect to wifi or to mobile internet when you connect to the router A?

I didn’t reset the routers but reset the vpn server/client to no avail.

Yes the IP is a valid public IP.

And tried using mobile internet which successfully connected to the vpn server.

One thing to check, both routers use as default IP address. You have to change at least one to others e.g. to connect two router.s

I think this wouldn’t be applicable in my case, where one router is connected through tethering while the other through WAN (so they are not on the same network).

If you use wireguard to connect the two, you need to change LAN IP tp different ones. Because once they are connected, LAN IP matters.

Tried this anyway. Changed the server IP to and still cannot connect.

This is a related older thread, describing the exact issue I have. But it’s not clear how it was resolved.

In the wireguard client side, you can check the config and find port, which is added automatically by the router. Can you try to change that port and try?

Otherwise, are you able to generate a wireguard config to try? Just send from private message.