GL-AR150 Wireless Scan suddenly stopped returning results

I have two GL-AR150 Routers, both with 5dBi antennas. Since about 1 week one of the routers has suddenly stopped returning any results when scanning for wireless networks. Screenshot 1 shows nearby WiFi networks which my Mac detects readily, but the GL-AR150 doesn’t. The router is right next to my laptop. Screenshot 2 shows the output from the command line when I run the “iwlist scan0 scan” command. Basically tells me that the Interface doesn’t support scanning.

To note - the other GL-AR150 is running just fine, and all the scanning functions work properly.

I have performed the necessary factory resets, re-uploaded the latest firmware, etc.

If you need any specific troubleshooting output, I will be happy to provide it.

what firmware are you using? I saw you have “scan0” interface, what mode is this?

Maybe you can try:

iw dev phy0 scan

I re-flashed the router to the latest firmware (2.24) a while ago, and cleared out all the saved configurations when re-flashing the firmware. It has now gone back into its default settings, with the IP address, and the SSID GL-AR150-357.

I tried the Wireless Scan again, with no luck. The attached screenshots show the results of the router before and after the wireless scan, and the attached text file contains the outputs of the commands you mentioned, plus a few more that I thought might come in handy for diagnosis.


sorry, should be

iwinfo dev phy0 scan

can you try?

Hi, I tried those. Here are the results:

root@GL-AR150:~# iwinfo
wlan0 ESSID: “GL-AR150-357”
Access Point: E4:95:6E:40:83:57
Mode: Master Channel: 11 (2.462 GHz)
Tx-Power: 18 dBm Link Quality: 35/70
Signal: -75 dBm Noise: -95 dBm
Bit Rate: 65.0 MBit/s
Encryption: mixed WPA/WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11bgn
Hardware: unknown [Generic MAC80211]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: yes PHY name: phy0

root@GL-AR150:~# iwinfo dev phy0 scan
No such wireless backend: dev

root@GL-AR150:~# iw dev phy0 scan
command failed: No such device (-19)

root@GL-AR150:~# iwinfo phy0 scan
Scanning not possible

root@GL-AR150:~# iw phy0 info
Wiphy phy0
max # scan SSIDs: 4
max scan IEs length: 2257 bytes
max # sched scan SSIDs: 0
max # match sets: 0
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Device supports AP-side u-APSD.
Device supports T-DLS.
Available Antennas: TX 0x1 RX 0x1
Configured Antennas: TX 0x1 RX 0x1
Supported interface modes:

  • IBSS

  • managed

  • AP


  • WDS

  • monitor

  • mesh point

  • P2P-client

  • P2P-GO

  • outside context of a BSS
    Band 1:
    Capabilities: 0x116e
    SM Power Save disabled
    RX HT20 SGI
    RX HT40 SGI
    RX STBC 1-stream
    Max AMSDU length: 3839 bytes
    Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
    Minimum RX AMPDU time spacing: 8 usec (0x06)
    HT TX/RX MCS rate indexes supported: 0-7

  • 2412 MHz [1] (18.0 dBm)

  • 2417 MHz [2] (18.0 dBm)

  • 2422 MHz [3] (18.0 dBm)

  • 2427 MHz [4] (18.0 dBm)

  • 2432 MHz [5] (18.0 dBm)

  • 2437 MHz [6] (18.0 dBm)

  • 2442 MHz [7] (18.0 dBm)

  • 2447 MHz [8] (18.0 dBm)

  • 2452 MHz [9] (18.0 dBm)

  • 2457 MHz [10] (18.0 dBm)

  • 2462 MHz [11] (18.0 dBm)

  • 2467 MHz [12] (disabled)

  • 2472 MHz [13] (disabled)

  • 2484 MHz [14] (disabled)
    valid interface combinations:

  • #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
    total <= 2048, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz }

  • #{ WDS } <= 2048,
    total <= 2048, #channels <= 1, STA/AP BI must match
    HT Capability overrides:

  • MCS: ff ff ff ff ff ff ff ff ff ff

  • maximum A-MSDU length

  • supported channel width

  • short GI for 40 MHz

  • max A-MPDU length exponent

  • min MPDU start spacing

Basically, no luck :frowning:

@alzhao, any further inputs? Is this something that can be solved?

Sorry just come back from vacation. The correct command should be

iwinfo phy0 scan

Hi alzhao, I ran that command already. It says:

root@GL-AR150:~# iwinfo phy0 scan
Scanning not possible

In my post #38401, I have pasted the output of a few other commands as well, if that helps.


– Saumil

Does its own wifi still broadcasting? Can you connect to it via wifi?

If not, then seem art is damaged.

Can you also check if the antenna connection is good? sometimes when you rotate the antenna too often it wire breaks inside.

@alzhao, Yes, I can use it as a normal WIFI Access Point, and I can connect to it from my computer and even plug it into my wired Ethernet to route packets and everything. As a WIFI Access Point, it is functioning perfectly well. The antenna connection is also good. I replaced the antenna with the other GL-AR150’s antenna to test as well, and both antennas work just fine. If there is any internal or physical test you would like me to perform, I can do that too.