GL-AR150 wont turn on

i buyed this GL ar150 router from amazon in order to download torrent using openvpn and its works great the first day (yesterday) today i powerd it up it wont turn on . when i plug the micro usb cable to the usb port on my laptop it wont turn on . i tried with several usb adapters 1A 2A the same result ( green led blinking one time then the router wont turn on !)
any suggestions plz ?
sorry for my bad English

So only the left green LED is on? Or it just blink one time then goes off?
Wifi led (the one on the right) doesn’t turn on?

Not sure what is going on there. If you can try repairing it using uboot as here Debrick via Uboot - GL.iNet Docs then please have a try.

If no LED is on maybe the router is broken and please get one exchange.

thank you for your answer, just the led in the middle than blink one time when i plug the micro usb cable .the other led dont turn on . i have tried to enter to uboot but the router wont turn on

If no LED is on, then make sure cable and power adapter are good. Otherwise, please exchange the router.