GL-AR300 dropbear sshd prompting for password always

This is my 2nd GL AR300 and I am trying to set it up. I had ssh port forwarding enabled on port 2222. I have added my pub key to /root/.ssh/authorized_keys. When I try to ssh, I am still prompted for password. My old AR300 had pre-LEDE build on it. The ssh worked with public key flawlessly.

I spent an hour so far trying to get this working, but making no progress. Appreciate any help.
Below is how I uploaded public key:
[~/work/glinet] ssh-copy-id -i ~/.ssh/id_rsa -p 2222 root@
/usr/bin/ssh-copy-id: INFO: Source of key(s) to be installed: “/c/Users/droidvideo/.ssh/”
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed
/usr/bin/ssh-copy-id: INFO: 1 key(s) remain to be installed – if you are prompted now it is to install the new keys
root@’s password:

Number of key(s) added: 1

Now try logging into the machine, with: “ssh -p ‘2222’ ‘root@’”
and check to make sure that only the key(s) you wanted were added.

[~/work/glinet] ssh -p ‘2222’ -i ~/.ssh/id_rsa ‘root@’
root@’s password:



Have you tried to add your ssh key via luci? You can find it under System > Administration

I did. I also checked authorized_keys under /etc/… folder. That didn’t make any difference

You need to add to /etc/dropbear/authorized_keys

I did that too. That didn’t work. I deleted and recreated /etc/dropbear/authorized_key file. Then I did “/etc/init.d/dropbear restart” and reload. Then it worked.