Gl-ar300m-20e "Warning: No Internet"


I am no expert and merely a private user so bear with my description of the issue.

I had to reset the Router to the factory settings. After that I uploaded my previously working Openvpn script which also worked fine. The moment I tried to apply the Client it loads for a few seconds and then gives me a notification “Warning: No Internet”.

As I said I am no expert but the Internet connection is supposed to be working through the OpenVPN Client in my student dorm so I dont quite get how it needs a connection to establish one.

I wanted to install the old firmware to uncheck the force VPN button which is missing in the new UI. But no matter which file I use it always says “Wrong firmware Format”.

I hope you understand the issue I am facing and thanks for help in advance.


Your firmware download type is wrong, follow the screenshot below to download

Thank you. That one worked. I actually used the 2.271 one to be able to stop forcing “No Internet without VPN”. That way I could apply my OpenVPN Client and everything started working again. Still I dont get why the new UI doesn’t allow me to do that.

Problem solved though.

Thanks everyone.