GL-AR300M Cannot revert to older firmware, cannot boot NAND


I had not used my ar300m for a while, and fired it up last night to make sure it was still OK. While I was making sure it was OK, I updated to firmware 2.27. The device is still working Ok, but now it seems to only boot into the NOR firmware now. I have tried reverting to the factory default, but the device remains on 2.27.

I have also tried uploading/flashing the prior firmware (2.261, 2.264) but receive the message " Error: Firmware is not for this hardware."

The WiFi now shows default ID as GL-A300M-b0f-NOR.

How can I return this device to the previous state of booting into NAND?


If it is brick, you should debrick it on u-boot. Guide to debrick.

Hello, thank you for the reply.

I do not think it is “bricked” as it works fine - I simply cannot get it to boot into NAND (does that qualify as being “bricked”?). Can you verify that the solution you have provided fits this particular situation? I normally define bricked as being totally inoperable.

And, FYI, I have tried just about everything I could find on this forum (and others) and nothing has worked so far.

Thanks again.


In general, it will boot from NAND, unless failing to boot from NAND, but it will try three times if failing.

In this case, I consider the NAND firmware is broken.

You can try to upgrade it.

1 Like


Problem solved.

Following the protocol you suggested to “de-brick” in u-boot did the trick.

Thanks man!