GL-AR300M-ext factory reset to 2.27 impossible to upgrade

Hi all,
I have a GL-AR300M-ext and some days ago automatically upgraded to 4.36 release but it lost some configurations.
So I had the bad idea to performed a factory reset and now I have 2.27 firmware :frowning:
I tried to download last firmware to upgrade but without success… Web Interface says me that is a wrong hardware.
Please could you show me the correct procedure or give me, I think, an intermediate firmware I can install?
Also automatical upgrade is not working I think because is a too-old version

Thank you very much!!!

Did you try to manually upgrade it to Version:** 3.105?

thank you for your answer,
I tried but it doesn’t work :face_exhaling:

Next stop - Uboot?

the only way to make it working is using openwrt-ar300m16-3.216-0321-1679391734.bin in Uboot that is for AR300M16, my model is GL-AR300M-ext I read that there is a NOR and a NAND memory, when I use Uboot I only can upload .bin files from AR300M16 model other files .img for AR300M Shadow (ext i think this is the correct) are not recognized … also wifi SID is called: " GL-AR300M-c31-NOR" how can be sure to be booting fron NAND partition?

I have this…

root@GL-AR300M:~# fw_printenv
tools/env/fw_env_main.c(219)test fw printenv
tools/env/fw_env.c(1515)=== env open
tools/env/fw_env.c(1535)have_redund_env = 0
tools/env/fw_env.c(1335)=== flash read buf
tools/env/fw_env.c(1559)crc0 = 184422182, crc = 184422182
tools/env/fw_env.c(1563)crc0 ok = 1
tools/env/fw_env.c(479)lf=if ping $serverip; then tftp 0x80060000 $firmware_name && erase $firmware_addr +$filesize && cp.b $fileaddr $firmware_addr $filesize; if nand bad; then run dlf; fi; else echo ping $serverip failed; fi
tools/env/fw_env.c(479)rlf=if ping $serverip; then tftp $loadaddr $firmware_name && erase $firmware_addr +$filesize && cp.b $fileaddr $firmware_addr $filesize && echo OK!; else echo ERROR! Server not reachable!; fi
tools/env/fw_env.c(479)dlf=if ping; then echo ok; elif ping; then echo ok; elif ping; then echo ok; elif echo ping; then echo ok; elif echo ping; then echo ok; else echo ping finally failed; fi; tftp 0x81000000 openwrt-gl-ar300m.img && nand erase && nand write $fileaddr 0 $filesize
tools/env/fw_env.c(479)lu=if ping $serverip; then tftp $loadaddr $uboot_name && erase $uboot_addr +$uboot_size && cp.b $fileaddr $uboot_addr $filesize && echo OK!; else echo ERROR! Server not reachable!; fi
tools/env/fw_env.c(479)lc=tftp 0x80100000 config.bin && cp.b 0x9fff0000 0x81000000 0xffff && cp.b 0x80100000 0x81000000 0x40 && cp.b 0x80100000 0x81001002 0x06 && erase 0x9fff0000 +0xffff && cp.b 0x81000000 0x9fff0000 0xffff
tools/env/fw_env.c(479)bootargs=board=ar300m console=ttyS0,115200 ubi.mtd=5,2048 root=/dev/mtdblock8 mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env),128k(reserved),64k(art);spi0.1:2m(kernel),20m(rootfs),106m(data),22m@0x0(firmware) rootfstype=squashfs,jffs2 noinitrd
tools/env/fw_env.c(479)bootcmd=nboot 0x81000000 0 0
tools/env/fw_env.c(1722)=== env close

root@GL-AR300M:~# df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 10.3M 10.3M 0 100% /rom
tmpfs 60.4M 128.0K 60.3M 0% /tmp
tmpfs 60.4M 140.0K 60.2M 0% /tmp/root
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mtdblock5 3.6M 796.0K 2.8M 21% /overlay
overlayfs:/overlay 3.6M 796.0K 2.8M 21% /

Thank you very much!

I upgraded U-boot to uboot-gl-ar300m-20220216-md5-97ff7bb80cbf129fa21f34ded1559ff8.bin to be able to upload new images and selecting NOR or NAND.
When I go to I select the image and I go to “upload” I got immediatly “connection reset” and image is not uploaded.
If i go to i can flash and upgrade uboot correctly, but not firmware in main page after selecting them because of this connection reset.

Thank you very much!

last time I was using wrong image :frowning: not uboot image! (the key is not to do this things during the night :slight_smile: :slight_smile: :slight_smile: )

Thank you very much!!!