GL-AR300M-ext not finding all SSIDs

New GL-AR300M-ext. Upgraded to firmware 2.264. On the Web UI under Internet Settings -> Repeater the SSID dropdown does not list all of the available WiFI networks. Most of the time it finds only one of the available networks. Sometimes none.

There also seems to be no way to manually enter a SSID if one is not detected.

Thank you.

More information:
Under the LuCI configuration, doing a WiFI scan reveals that the networks are showing as “hidden”. However, on my router the SSIDs are clearly configured as public broadcast, and are detected by other devices. I’ve never had a problem with other devices not seeing the SSIDs. The SSIDs in question are from Cisco Meraki wireless access points running the latest stable firmware.

I have this same issue often when staying at Holiday Inn hotels. For some reason I cannot see the SSID no mater what I try. The only way I can get it to work (usually) is to manually change a saved SSID to the one for the Holiday Inn SSID.

I can see the SSID on my phone, tablet and computer but not on my AR300M.

What channels are the “hidden” SSIDs? It might be that they are on 12 or above.

A lot of newer, industrial-size WiFi build-outs use DFS to coexist with radar, so I’ve noticed more jumping around with SSIDs and APs on-the-fly in larger build-outs. I live in a largish complex (three 24-story buildings) with its own WiFi system included (just installed a couple months ago), not to mention a ton of personal routers broadcasting from each apt, so I’m always seeing wacky stuff occurring all over the place. Plus, I can see the same SSID from a dozen different APs/BSSIDs, and the building broadcasts the same SSID for both 2.4 and 5Ghz, so I have no choice than to use Luci or the command-line to figure-out what is what (the GL interface just gives a list of duplicate SSIDs with no way to differentiate). I’ll frequently see the building’s SSID as “not supported” due to DFS on certain APs – not sure if this is relevant to you.

In any case, I’ve found the best way to get more verbose details as to what is going on with SSIDs is with the command-line:

# wpa_cli scan
Wait a few seconds...
# wpa_cli scan_results

Thank you for the advice. What are the command line commands or configuration file to select the SSID that the GL-AR300M connects to? I’m Linux/Unix sysadmin knowledgeable, but not familiar with OpenWRT.

The SSID’s that appear as hidden are on channel 11. It’s not a case where the router is limiting to 11 and below to meet US requirements and the APs are not. Note that the “hidden” SSIDs all show up when scanning from the LuCI Web UI.

I will also try scanning from the command line.

One of the two web interfaces (GL or Luci) are still the best way to config things if you can, but if you need to do so, the command-line stuff is mainly done via the “uci” command interface, which edits everything under “/etc/config” using standard-formatted config files. The “wpa_cli” command is a more low-level command that I generally use for read-only stuff, like checking status and debugging. Another good command to check your actual connection is “wpa_cli status”.

The wireless stuff is in the file “/etc/config/wireless”. If you are making a “WISP” repeater connection, the relevant section is “wlan-sta” device (assuming an initial connection attempt has been made – otherwise, that section may not exist yet). Note that if you are doing a repeater connection like WISP, you can’t actually set the radio channel – that will be determined by the AP you are connecting to, so I always set it to “auto”.

I ended-up doing a rudimentary setup using the GL web interface as a bootstrap, and then edited the “/etc/config/wireless” file by hand to be what I wanted (2.4 vs. 5GHz radio, BSSID, etc). I should’ve mentioned that I have an ar750, which is dual-radio, and why 2.4 vs. 5GHz is relevant for me. If you do edit the file by hand in a text editor (as opposed to using “uci”), the WiFI config can be reloaded with the command “wifi reload”, or just reboot. If you want to see all the gory details of what can go into “/etc/config/wireless”:
https://openwrt.org/docs/user-guide/wifi/basic

Thank you! This is exactly what I was looking for to get started.

I had started a thread about this at one point but it never caught traction:

In the case shown here it was channel 1.

I don’t pretend to know the dynamics of network scanning and how it’s interpreted by access points. I would have thought it was a passive action. However, I found a workaround for this hotel access point issue. I connected to the hotel access point with my phone and then cloned the MAC address to my GLINet router. I then disconnected my phone from the hotel wifi and I was able to scan the hotel access points and connect. They no longer appeared as hidden and connecting was no longer a problem.

This is interesting and I don’t know how this happen.

But in the recent update we already added manually connect to hidden ssids

I am encountering the issue on the AR750S-EXT with the most recent released firmware and was not able to manually connect to the access point until I did what I described above. I am in the hotel for the next week and am happy to try alternate firmware to assist in diagnosing the problem if you like.

I do want to be clear though… these SSIDs aren’t hidden. The mini router reports them as all hidden but on my laptop, phones, etc. the SSIDs appear as fully visible. I attempted to manually enter the SSIDs and it did not work as a solution. Once I connected with my phone to one of the hotel access points and then I cloned the MAC address from my phone to the mini router, the access point names appeared correctly in the scan with the mini router.

Maybe it filter the MAC address? The same issue with MT300N-V2 won't find hotel WiFi networks

Does it work on old firmware?

The AR750S-ext has the same problem all the way back to the original firmware. I rolled it back to confirm and same thing.

As for why it works when I clone the MAC address, I can’t explain that. I would have thought scanning for access points only involved listening and so the access points would be unaware of the mini routers MAC address. Further to that, why did my laptop and phones not have an issue seeing the SSIDs but my minirouter did right from the beginning before any connections were made? Maybe its some security feature they have enabled on the hotel network that’s causing it since there is some indication the minirouter is not a normal client device???

I do know they have rogue access point containment enabled because I cannot setup a hotspot on 2.4ghz. Neither with my minirouter nor phone. I can set it up but no clients can connect. They de-auth immediately on connection. So, my hotspot with my minirouter is setup on 5Ghz.

If you associated with the AP, then de-auth immediately, it might caused by rogue containment.

But if you can’t scan the SSID, it is very strange.