Gl-ar300m - howto vlan


#1

Hello,

how do I configure a vlan on eth1?
simply by configuring under “physical interface” a custom interface, like “eth1.3” for participating in vlan number 3? On the switch port I have to define a tagged port for vlan 3, right?

Regards
Mikee


#2

For your information.

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.3'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-AR300M-ff3'
	option ipaddr '192.168.9.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'
	option hostname 'GL-AR300M-ff3'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '1 0t'

#3

Thank you, kyson-lok! :robot:


#4

Hello Kyson-lok,

no chance to get a tagged configuration running.

Running untagged configuration is (no switch configuration on gl-ar750):

switch (phy)          -----         switch (gl-ar750)    ------  switch (gl-ar750)   ----------  switch (phy) 

1 (untagged vlan 3)  -----     wan eth0.3     -------     eth1     ----------    1 (untagged vlan 4)

If I try to define tagged ports on the gl-ar750, no communication to lan and wan ports is possible, although using the vlan switch switches on gl-ar750, like you have shown before.

I am at reset count 60, I believe. :slight_smile: