GL-AR300M-LITE Booting Mystery

Got this new from Amazon yesterday. When I booted it without a wired connection on the WAN interface the wireless light would flash but I was never able to connect. I brought it downstairs and connected it to my home network and magically it started working, I was pretty impressed. It told me there was a software update and I ran that, rebooted, still good. I changed the wifi to 300 and changed the password, still all good. Then I told it to reboot from Advanced (openwrt) interface and it never came back. Now the wireless light never lights up and I am dead in the water. I have held the reset button for three flashes and let go, the green light never comes on again, and multiple reboots after yield no changes. I’ve held the reset for 8 seconds (manual says 10, but saw somewhere here that the 8 seconds is the norm now), which the manual says will reset it to factory defaults. The green light stays on and nothing ever happens, power cycled it after 20 minutes and it still just sits with the red light on but no green. More reading, sounds like holding reset will put it into uboot recovery, but as this does not have a LAN interface I cannot connect to it unless wifi comes up. Soooo…what now? How do I get this to unbrick itself, and once I do, what will make it boot consistently?

Uboot with Ethernet plugged into WAN :confused:

Red light solid, green light solid, zero responses from the WAN interface. I set my wired interface to 192.168.1.2/24, tcpdump to watch as I try and reach 192.168.1.1, I get zero frames back. :frowning:

I’m pretty sure it’s just defective. Half the time when I hold the reset button before and during inserting the power plug I dont even get the green lights.

Opened the case, the serial header isnt present. Send it back or solder the header on?

(Side note, if you were not afraid to do so, could you not solder the LAN port onto the AR300-M LITE? Would it work?

@alzhao I know you’re a busy man, can I bother you to weigh in on this?

It was just holiday.

If you can solder the LAN port it will work as well. But I don’t think you can find a physically match LAN port.

Let’s use Left, middle and right to name the LEDs. The left LED should always be on because it indicate power.

The right LED indicate wifi. If it is on, then it means the router boot up. Now if you press down the reset button, the power LED will start to flash, once per second. It will flash twice per second after 3 seconds. It will flash 4 times per seconds after 10 seconds. Then release your finger it will reset.

If the right LED doesn’t light up. It mean your wifi is turned off or the router doesn’t boot at all. But you can still press the reset button. If the left LED start to flash, then you can reset the router.

If you press down the reset button but the left LED doesn’t flash. It mean the router didn’t boot. You can use uboot to reflash the router.

There is the guide: https://www.gl-inet.com/docs/mini/ar300m/#debrick

Remember, reset the router only works after the router boot. If you press and hold the button while powering on, you need to check uboot guide as above.

Thanks for the reply, and I hope you had a nice holiday. :slight_smile:

At the moment no amount of power cycling or button holding will light the right or center led. The left led, power (red), comes on but nothing I do seems to effect the center or right leds, both green. The switch doesnt have any effect on booting, correct? I’ve tried that in both positions as well and gotten no new response.

At the moment I have an unresponsive brick. If I solder the header on will that void my chance at returning it later if there is indeed some hardware trouble?

The switch doesn’t have any effect in booting before you set it manually in uboot or using fw_setenv

So even uboot web failsafe doesn’t work?

Tonight I was able to get into uboot, not sure why I wasnt before. I had already downloaded “openwrt-ar300m-2.264.bin”, even though I havent messed with the firmware on this little fella yet. I selected NOR upload and waited; all the while watching tcpdump. It never uploaded the file, I waited 8 minutes then rebooted it and tried again, still wont upload. I dont get an error per se, it just times out. I read the forum, saw there used to be issues with MTU, I’m on a Mac so I lowered it and tried again, no good, still get the timeout. At one point it looked like it might be uploading very slowly, waited 10 minutes, it timed out. Now I cannot get into the uboot, so I’m guess it “might” have been working and I killed it mid-flash somehow? The next time I uboot’ed it refused to serve the page and the tcpdump I’ll paste below.
At the moment it’s mad at me again and refusing to blink green with the reset button held down, I’ll try it again tomorrow. I ordered a USB TTL, should be here in a few days. Is there a chance I have better luck with that? Thanks for your time @alzhao , I appreciate it.

$ tcpdump -nn -i en4 tcp or arp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on en4, link-type EN10MB (Ethernet), capture size 262144 bytes

01:38:50.059023 ARP, Probe 192.168.1.2, length 28
01:38:50.380287 ARP, Probe 192.168.1.2, length 28
01:38:50.700802 ARP, Probe 192.168.1.2, length 28
01:38:51.021589 ARP, Announcement 192.168.1.2, length 28
01:38:51.346861 ARP, Announcement 192.168.1.2, length 28
01:38:51.672495 ARP, Announcement 192.168.1.2, length 28
01:38:54.958283 ARP, Request who-has 192.168.1.2 tell 192.168.1.1, length 46
01:38:54.958408 ARP, Reply 192.168.1.2 is-at 98:5a:eb:d3:81:d3, length 28
01:38:59.958282 ARP, Request who-has 192.168.1.2 tell 192.168.1.1, length 46
01:38:59.958366 ARP, Reply 192.168.1.2 is-at 98:5a:eb:d3:81:d3, length 28
01:39:04.958214 ARP, Request who-has 192.168.1.2 tell 192.168.1.1, length 46
01:39:04.958256 ARP, Reply 192.168.1.2 is-at 98:5a:eb:d3:81:d3, length 28
(here is where I requested the page, before I was seeing GETS, now no response)
01:39:06.474093 IP 192.168.1.2.51726 > 192.168.1.1.80: Flags [S], seq 1086990366, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1093922342 ecr 0,sackOK,eol], length 0
01:39:06.724397 IP 192.168.1.2.51727 > 192.168.1.1.80: Flags [S], seq 4102548801, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1093922592 ecr 0,sackOK,eol], length 0
01:39:07.475334 IP 192.168.1.2.51726 > 192.168.1.1.80: Flags [S], seq 1086990366, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1093923342 ecr 0,sackOK,eol], length 0
01:39:07.726510 IP 192.168.1.2.51727 > 192.168.1.1.80: Flags [S], seq 4102548801, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1093923593 ecr 0,sackOK,eol], length 0
01:39:08.476578 IP 192.168.1.2.51726 > 192.168.1.1.80: Flags [S], seq 1086990366, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1093924343 ecr 0,sackOK,eol], length 0
01:39:08.727307 IP 192.168.1.2.51727 > 192.168.1.1.80: Flags [S], seq 4102548801, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1093924593 ecr 0,sackOK,eol], length 0
01:39:09.478462 IP 192.168.1.2.51726 > 192.168.1.1.80: Flags [S], seq 1086990366, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1093925344 ecr 0,sackOK,eol], length 0
01:39:09.728038 IP 192.168.1.2.51727 > 192.168.1.1.80: Flags [S], seq 4102548801, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1093925593 ecr 0,sackOK,eol], length 0

There must be something wrong.

You do see there are two file input to upload the file, right?

The MTU problem mainly happen in very old uboot, should not in this version.

Had a few minutes to mess with this again, got right into uboot menu, and the file uploaded quickly and easily. I used the NOR upload the same as before, I truly believe I’ve followed the exact same steps. It took about 5 minutes to reboot on its own, now I am sitting with the solid left (red) led again; wifi never comes up. Should I go to an earlier firmware than “openwrt-ar300m-2.264.bin”? Have there been problems with this v1 release on the LITE versions?

Just rebooted it again as I type this, the right and center green leds never light after the initial moment when you apply power. The serial cable came today, trying to decide if I solder the serial header on this puppy or just send it back to Amazon.

The mystery of when it will and wont enter uboot still boggles me, seems like I have to let it rest for 15 minutes after messing with it to get the uboot upload screen again.

I uploaded “lede-17.01.4-ar71xx-generic-gl-ar300mLite-squashfs-sysupgrade.bin” that @bluewavenet created, took five minutes to reboot itself. Appeared to enter a boot loop, unplugged ethernet and now sitting at solid red again. @bluewavenet, since you have some of these running on this firmware can you tell me what the expected behavior is if I boot it with only power and no ethernet? From your other post I expected wireless to come up, but I wasnt sure if it had an “ethernet up” requirement perhaps?

Giving up on this one, feels too much like a hardware issue and returning it, this thread can be locked. The AR300M (with NAND) went out of stock right before I decided to buy, so I went with the LITE. Already ordered the AR300M16-Ext, hoping it fairs better, I’m ready to write a shining review and move forward with my project! :smiley:

Thanks for accompanying me on this magical journey. :wink:

@lurkio
I just read over this thread.
What USB power supply are you using?

The history of USB power supplies mainly began as chargers for small mobiles and these were generally rated for around a maximum of 500mA and were not particularly well regulated in output voltage ranging from 8 volts with no load down to 3 volts when charging a flat battery.

Then smart phones/tablets etc came out and much improved USB power supplies came out with them.
A modern USB power supply with have a continuous output anywhere from 1 A to 2.5 A with a minimum voltage of 5 Volts at maximum current.

Now going back to the AR300M, this has a very low standing current BUT CAN draw 500 mA to 600 mA or even more for milliseconds at a time when it is busy or wireless is transmitting. Setting the wireless to 40MHz bandwidth (300 mode) doubles the power requirements for the instant a packet is transmitted.
The SoC (combined CPU, wireless and ethernet chip) needs a regulated 3 volts it gets from the AR300M’s internal regulator.
IF the USB power supply output drops below 5 volts, the internal regulator cannot maintain its stable output to the SoC and this will make the SoC become unstable or even crash.

I hope you are with me so far :wink:

Your original post stated the wireless did not come up initially but then it did. (unstable, now you see me now you don’t behaviour).
Then you managed to switch the wireless to 300 mode and that was the last you saw of it!

You managed to get into uboot and attempted to reflash with my firmware with the wireless on by default and it would not boot. One of the most power hungry things you can do is reflash.
My guess is the reflash was corrupted due to an inadequate USB supply.

You might have been very unlucky and received a faulty unit, but I have bought many of these and reflashed with my own custom firmware and sold them to my customers with not a single failure so far.
So my guess is you have a power problem.

FYI I always supply an Amazon Basics 2.4 amp Wall charger, very cheap and high quality.
The UK version of this is ASIN B01FI2P0WW and there will be versions for your country I am sure.

If you have not yet sent your Lite back, check out the USB supply first. If this is the problem then you will get the same problem with an AR300M16

@lurkio

i have AR300M with NAND in stock, just write a mail to info@minirouter.de and we can arrange shipping if you want to buy.

Seems this is a bug in uboot and the firmware was not uploaded actually.

As you have the ttl connector and this will help.

First connect the TTL and USB UART from your pc to the router. Make sure it is wired correctly and you can enter the uboot console in your terminal.

press any key to stop in uboot console. Then type httpd to start the web failsafe UI.

Other steps should be the same. Using the uboot console seems more reliable than using the button.

Thanks for the reply @blue-wavenet. I’d be lying if I said I hadnt wanted to dismiss the power idea. The adapters I’ve used were Samsung and should be fine, but I dug out an iPad 10W adapter (5V 2.1A), and with a meter on it I fired up the 300M LITE. The second attempt did get the uboot page, and the upload of your firmware took right away. The reboot came more quickly, maybe a minute in, but I still observed the subsequent reboots. Eventually the LEDE wifi became available, but the default setup page was never reachable, and twice it rebooted itself while waiting for some response. Now that I could get into uboot reliably I figured I’d load the GL code back on it, the upload went quickly but once rebooted the wifi never came up. Now I cant get uboot back, so for now I think I am going to just go ahead and send it in. The 300M16-Ext will be here tomorrow and I’ll see how that goes.

With the Apple 10W adapter I observed a supply voltage of 5.11V when unattached. Once booted it would draw at 5.08V and .19A, dropping to .16A once the boot sequence was complete. There was no significant increase for the upload or install, and unfortunately I didn’t get my USB meter out until “after” I was no longer able to get WiFi up. I suck, sorry. But, I still believe that a 10W adapter would supply enough volts to keep this guy stable. If I experience weirdness with the AR300M-Ext I’ll go to the Amazon basic 12.5 Watt you suggested. Thanks!

Back on the GL code, I think you’re right, I think the webserver just isn’t up. Unfortunately, I doubt I can return this baby if I solder the header on, Amazon probably wouldn’t like that. If I hadn’t already had the 300M-Ext arriving tomorrow I think I’d bust the soldering iron out and get going, after all a $17 dollar brick wouldn’t be the end of the world. If you think Amazon won’t care/notice then I’ll still try the header before I give up. After all, the tcpdump makes me think your assessment is correct.

20:57:37.351864 ARP, Probe 192.168.1.2, length 28
20:57:37.677172 ARP, Probe 192.168.1.2, length 28
20:57:38.001309 ARP, Probe 192.168.1.2, length 28
20:57:38.322835 ARP, Announcement 192.168.1.2, length 28
20:57:38.648115 ARP, Announcement 192.168.1.2, length 28
20:57:38.973680 ARP, Announcement 192.168.1.2, length 28
20:57:42.100457 ARP, Request who-has 192.168.1.2 tell 192.168.1.1, length 46
20:57:42.100593 ARP, Reply 192.168.1.2 is-at 98:5a:eb:d3:81:d3, length 28
20:57:47.100389 ARP, Request who-has 192.168.1.2 tell 192.168.1.1, length 46
20:57:47.100474 ARP, Reply 192.168.1.2 is-at 98:5a:eb:d3:81:d3, length 28
20:57:52.100339 ARP, Request who-has 192.168.1.2 tell 192.168.1.1, length 46
20:57:52.100375 ARP, Reply 192.168.1.2 is-at 98:5a:eb:d3:81:d3, length 28
20:57:57.100448 ARP, Request who-has 192.168.1.2 tell 192.168.1.1, length 46
20:57:57.100536 ARP, Reply 192.168.1.2 is-at 98:5a:eb:d3:81:d3, length 28
(this looks good, time to request the page!)
20:58:02.032823 IP 192.168.1.2.58827 > 192.168.1.1.80: Flags [S], seq 4136883397, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1127572824 ecr 0,sackOK,eol], length 0
20:58:02.287486 IP 192.168.1.2.58828 > 192.168.1.1.80: Flags [S], seq 2080174911, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1127573078 ecr 0,sackOK,eol], length 0
20:58:03.036491 IP 192.168.1.2.58827 > 192.168.1.1.80: Flags [S], seq 4136883397, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1127573824 ecr 0,sackOK,eol], length 0
20:58:03.290651 IP 192.168.1.2.58828 > 192.168.1.1.80: Flags [S], seq 2080174911, win 65535, options [mss 1460,nop,wscale 5,nop,nop,TS val 1127574078 ecr 0,sackOK,eol], length 0
(well, it was worth a shot…server doesnt appear to be up)

@lurkio @alzhao
Re power supply, you really need an oscilloscope to see the voltage drops, on sending a burst of wifi I have seen a usb supply output drop well below 3 volts, albeit for just a few milliseconds or so and this was enough for the GL mini router to drop wifi, reboot or lock up. This was with a Samsung 1 amp. Nothing wrong with the supply or the mini router, the supply designed for charging a battery and the mini router designed for a 5 volt input.
Having said that, this has been very rare and always with a very old usb supply.

Having now reflashed quite a few of these, initially I did find it a bit hit and miss. Now I have my technique :wink:
I set my laptop to static ip 192.168.1.2 mask 255.255.255.0
Connect the ethernet from my laptop to the AR300Mx
Start my laptop pinging 192.168.1.1
Press and hold the reset button then plug in the usb power (double jointed wrists and fingers or 3 hands an advantage :smiley: )
Keep that button pressed!
If you let the button go even slightly too soon, you will probably have to start again.
Once all the lights have stopped flashing you can let go. A few seconds later the ping will be returned and the uboot flash page will be up.
The time for the lights to stop flashing is maybe ~10 seconds.
For me at least I have been able to do this every time on any of the AR300x models I have had so far.

As for bugs reflashing with uboot, the only thing I have found is the maximum size of firmware file the uboot can handle is ~8MB
As the firmware I am flashing is 12MB, I have to do a two step reflash, first with a basic LEDE firmware that is only ~4MB, then using sysupgrade when rebooted. (I have automated this now too apart from the initial uboot bit).

This probably does not help for this one, but I thought I would share my experience.