GL-AR300M: Long video conference breaks Wi-Fi

Hi,

I’m using GL-AR300M in Router mode and experiencing the following issue: after a long video call (>= 1.5 hours) Wi-Fi becomes unstable. The longer call is the more unstable Wi-Fi becomes. Sometimes it comes to the point where authentication on Wi-Fi starts timing out.

There are a few things I noticed:

  • If I don’t make any video calls Wi-Fi works stably for days (downloading files form internet doesn’t seem to break it)
  • Restarting Wi-Fi from LuCi (https://192.168.8.1/cgi-bin/luci/admin/network/wireless) always helps. If Wi-Fi cannot authenticate anymore I have to connect using Ethernet cable to be able to restart Wi-Fi.
  • Trying to monitor traffic with tcpdump I noticed that when Wi-Fi is unstable network packets from Wi-Fi to laptop/mobile seem to go well, however packets from laptop/mobile rarely reach Wi-Fi device
  • Disabling WMM seem to help avoiding this problem however disabling it seems to limit Wi-Fi network bandwidth

Any suggestions?

Best regards,
Stanislav

1 Like

Upgraded to the latest version of OpenWRT (openwrt-19.07.3-ar71xx-generic-gl-ar300m-squashfs-sysupgrade.bin specifically). There is a feeling that overall network is faster and more stable however WiFi issues didn’t go anywhere. Here is how I can usually reproduce it:

  1. Create a Google Meet session and connect with two devices (laptop and android in my case, video is enabled on both).
  2. Wait for 20-40-60 minutes until WiFi hangs (no traffic moving anymore, no ability to connect to the access point).

Interestingly on the new firmware WiFi is not degrading slowly but stops working suddenly. Connecting through LAN and restarting WiFi from LuCI makes it work again. As I mentioned above disabling WMM helps to avoid the issue however this also makes the WiFi network a lot slower.

Any thoughts? How to debug? Is it hardware / driver / hostapd issue or something else?

The symptoms seem to be similar to this issue https://dev.archive.openwrt.org/ticket/13681

When this happens, you can use the top command to see the CPU load.

When this happens the CPU usage is low

Give me some time and I will simulate the test.