GL-AR300M not booting reliably - big problem

Having this issue with a new GL-AR300M:

  • First boot - no wifi or network, solid green light, left it on for 30+ minutes.

  • Reboot and hold reset for 10s = lights flash, then fade light

  • Reboot - solid green light, no wifi

  • Reboot another 3-4 times, finally it comes up - green + red lights, wifi works.

  • Update to 2.22, reboot - solid green light, wifi/network not working again.

Can you please provide instructions for how to solve this boot issue? I have two GL-AR300M and both are very very unreliable in booting, it works maybe 1 in 10 times, honestly I find this model completely unusable due to this and I would advise people not to purchase it until this gets sorted.

@Stanislav - I’m in the same situation. It seemed to work well for a while but I’m having a horrible experience myself. Same problems as you are seeing. I need to flash a new firmware to get it working again. Works for a while but then ends up as you described after a few boots.

@Stainslav would you like to ship back the device for investigation?

@LostDog, does this still happens now? If yes, please return for an investigation.

In our test, we tried to repeatedly write the nand flash, reboot the devices to make sure it works. But if you do have such problems please let us know.

hi @Stanislav and @LostDog, can you please try another power adapter, e.g. the one used for iPhone, or a PC’s USB port as power supply. I suspect this is related to the power adapter, which causes the nand flash to not work properly.



I’ve tried about four different power adapters including the USB port on my laptop, a 5V 1.5 amp, a 5V 2.0 amp and a 5V 1.0 amp. Same performance on all of them.

I’m having these same problems with an GL-AR300N I purchased in August.
Is an Apple iPad 2.4A adapter power enough?

Yes, iPad adapter is enough.

We tested some adapters and found the nand flash will have problems if power is not enough.

So please use a 5V2A adapter if you have.

Hey @alzhao,

I have exactly the same problem with mine. This is what I did when I got it (with 2A power input btw):

  1. Turn on, only green light flashing. Box is not reachable via Wifi and LAN. Not with and (ethernet was configured correctly)

  2. Reset box by holding reset button while powering the device. Flash interface is reachable via I don’t flash anything for now

  3. Unplug power, plug power back in without holding reset button.

  4. Green button is on for 2s, then turns off, red button is on for ~15s, then green button is blinking, WiFi is available. It seems first boot after flashing mode seems to work.

  5. Turn off again, plug power back in. Only green LED is constantly on. Can’t reach the box in any way.

  6. Using step 2.-4., reach web interface again and flash Firmware openwrt-ar300m-2.20.bin without keeping settings.

  7. Installs, reboots, only green LED is on, no WiFi, not reachable via LAN, WAN or WiFi. Repeating 2.-4. Interestingly this time I have to start the router twice before it comes back to life. I can reproduce this a second time. When I come back to the interface I see 2.20 is correctly installed

  8. Same issue with 2.20, so I flash openwrt-ar300m-2.22.bin again

  9. Now it’s the same thing, after disconnecting power it will only show green light as the OP said here. It’s the same problem. It’s unusable and I am disappointed. Seems that the AR150 runs much more stable than the 300M. Can we provide you with any logfiles? I think shipping it somewhere would be too expensive as I am in Europe, but I would happily do it.

It is definitely not the power. Tried several USB power devices and iPad power plug as well. Also, as it is reproduceable, I feel it is something with the firmware. The WiFi does work reliable every time after I set it to uboot firmware recovery mode and then reboot it again.


Edit: Exactly the same issues with firmware version 2.23-6. I really don’t get it, everything is really great except I have to start the router with reset, then restart it again 2 times and it works as usual.

can you ship back to Germany? I want to find out the problem with the router at hand?

Sure thing, I can send it back. Should I declare it as “broken”? I bought it via Amazon ( Anything they should know?

I have a setup automounting a USB stick via fstab already. Should I remove that or send you the whole thing with a usb stick (it’s a cheap one, i won’t miss it).


I don’t need the usb disk. Please return it to Amazon and declare it as broken. Please put a sticker on the router saying the problem (or just from forum z0rg) that would be very helpful to us.

Hey @alzhao,

I sent it back as broken yesterday. Wrote my nick in the Amazon form and on the piece of paper i put in the package. Will be interesting to see what you find out.


Hey @alzhao,

Can you tell where that router is right now and if you have any insights already? I am traveling more and more and I miss that beautiful little box. Probably I will wait until you release the ac version of the AR300M anyway. I am so looking forward to it, travel routers rock!

Hey z0rg,

i think the router you´ve received was a monday product :smiley:


I would just purchase another one and i think it would run great, i´m having no issues so far with it.


Hey Rene,

Agreed, however there are other people in that thread with the same issue. Still, something might be wrong with the product. You are right, I will just buy another one, because I could return it to Amazon again in the end.



Yup, I’m another one who has serious issues with my AR300M. A factory reset gets it to work but the next time I try and use it it locks up. Frustrating!

@z0rg, when did you send back to Amazon? I haven’t get it back. Sometimes Amazon throw away my stuff quickly before I get it back.

@LostDog, I uploaded firmware version 2.24. You can download from GL.iNet download center

AR300M firmware was having a problem in firmware 2.19. The data is not sync to the nand flash immediately. That means when you change something and reboot the router, all the unsaved data will be lost. But this has been fixed in later firmware by using “sync” everytime you change something in the UI. If you change something using ssh or luci, you can execute “sync” manually in ssh and data will be saved to flash.

I have 2 <span style=“color: #222222; font-family: source_sans_proregular, ‘Helvetica Neue’, Arial, Helvetica, Geneva, sans-serif; font-size: 14.6667px;”>GL-AR300M and both have been rock solid but both have holes where the antennas would go. It could be in need of a tiny heatsink. The holes help with ventilation. Neither one reboots and they both get to be VPN servers running 24/7. I’m running the 2.23 firmware on both.</span>

@dvdivx @Rene I bought another one from Amazon (the one with 2 antennas) and it’s just working as expected. There is still some issues with WiSP mode. So when you switch the Wifi it should relay it reboots Wifi and sometimes Wifi doesn’t come up properly. But it works a lot better than it did before. I try out the LEDE Project image right now, which also seems to work great so far. I have to say it’s a nice little piece of hardware! Still awaiting the AC module :slight_smile:


Edit: @alzhao I sent it back on 31st of octobre already. Should have arrived at Amazon on the 3rd or something of novenber.